aboutsummaryrefslogtreecommitdiff
path: root/security/pks
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2011-04-12 21:50:11 +0000
committerMatthias Andree <mandree@FreeBSD.org>2011-04-12 21:50:11 +0000
commit422593a798d12d4815d7726740c3c438b36a0dc0 (patch)
tree95f4991cb308224a26e1d5f6fc6656e46da3d7f5 /security/pks
parent1e27535f8a6cf32053d818efbc2df973aa870cd0 (diff)
downloadports-422593a798d12d4815d7726740c3c438b36a0dc0.tar.gz
ports-422593a798d12d4815d7726740c3c438b36a0dc0.zip
Notes
Diffstat (limited to 'security/pks')
-rw-r--r--security/pks/Makefile37
-rw-r--r--security/pks/distinfo5
-rw-r--r--security/pks/files/patch-configure.in129
-rw-r--r--security/pks/files/pkg-message.in2
-rw-r--r--security/pks/pkg-plist2
5 files changed, 151 insertions, 24 deletions
diff --git a/security/pks/Makefile b/security/pks/Makefile
index 736586707c00..718ab25dc7c5 100644
--- a/security/pks/Makefile
+++ b/security/pks/Makefile
@@ -5,48 +5,45 @@
# $FreeBSD$
#
-PORTNAME= pks
-PORTVERSION= 0.9.6
-PORTREVISION= 1
-CATEGORIES= security www
-MASTER_SITES= SF
+PORTNAME= pks
+PORTVERSION= 0.9.6.20040312
+CATEGORIES= security www
+MASTER_SITES= http://pks.sourceforge.net/:sf ${MASTER_SITE_LOCAL}:local
+MASTER_SITE_SUBDIR= .:sf mandree:local
+DISTFILES= pks-current.tgz:sf,local
MAINTAINER= gtodd@bellanet.org
COMMENT= PGP Public Key Server
-USE_BDB= yes
-WANT_BDB_VER= 2
+USE_BDB= 41 # 42 would be ok
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.pre.mk>
GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS= --datadir=${PREFIX}/share/pks --localstatedir=/var/pks \
--sysconfdir=${EXAMPLESDIR} \
--libdir=${LOCALBASE}/lib --with-libwrap
-CFLAGS+= -I${BDB_INCLUDE_DIR}
MAKE_ENV+= LDFLAGS=-L${LOCALBASE}/lib SUBDIRS=
+CONFIGURE_ENV= DBLIB="-L${BDB_LIB_DIR} -l${BDB_LIB_NAME}" DBINC=-I${BDB_INCLUDE_DIR} DBHDR=db.h
USE_RC_SUBR= pksd.sh
MAN5= pksd.conf.5
-MAN8= pks-intro.8 pksclient.8 pksd.8 pksdctl.8
-SUB_FILES= pkg-message pkg-deinstall
+MAN8= pks-intro.8 pksclient.8 pksd.8 pksdctl.8 pks-mail.sh.8 \
+ pks-queue-run.sh.8 pgpsplit.8
-# remove embedded sleepycat, remove associated build commands, make
-# the build use the headers and libraries from the db2 port
-post-patch:
- ${RM} -rf ${WRKSRC}/db2-sleepycat
- ${REINPLACE_CMD} 's|SUBDIRS =.*|SUBDIRS =|; \
- s|LIBDB =.*|LIBDB = -L${LOCALBASE}/lib -l${BDB_LIB_NAME}|; \
- s|DBDIR =.*|DBDIR = ${BDB_INCLUDE_DIR}|' \
- ${WRKSRC}/Makefile.in
+SUB_FILES= pkg-message pkg-deinstall
post-install:
${INSTALL_DATA} ${WRKSRC}/pksd.conf ${PREFIX}/etc/pksd.conf.sample
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/pks_help.en ${WRKSRC}/pks_help.es ${WRKSRC}/pks_help.fr \
- ${WRKSRC}/pks_help.cz ${WRKSRC}/pks_help.de ${WRKSRC}/pks_help.ja \
+ ${WRKSRC}/pks_help.cz ${WRKSRC}/pks_help.de ${WRKSRC}/pks_help.ja \
${WRKSRC}/mail_intro ${DOCSDIR}
PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/pks/distinfo b/security/pks/distinfo
index 13275f85e2aa..e2ba2cae4d92 100644
--- a/security/pks/distinfo
+++ b/security/pks/distinfo
@@ -1,3 +1,2 @@
-MD5 (pks-0.9.6.tar.gz) = 19427b543972c23fbc1c167d5408d3a9
-SHA256 (pks-0.9.6.tar.gz) = 419fff7df644ac11d92ca5b7981e0a6f1e10f74605eb1602f7b39e272d8b079c
-SIZE (pks-0.9.6.tar.gz) = 559872
+SHA256 (pks-current.tgz) = 839b63c7a4a0a6ef4c933f4205ac425ca5154c39ca32a7d9b79dc86b6d19c8b7
+SIZE (pks-current.tgz) = 217922
diff --git a/security/pks/files/patch-configure.in b/security/pks/files/patch-configure.in
new file mode 100644
index 000000000000..466af4727cc4
--- /dev/null
+++ b/security/pks/files/patch-configure.in
@@ -0,0 +1,129 @@
+--- ./configure.in.orig 2011-03-21 20:49:39.000000000 +0100
++++ ./configure.in 2011-03-21 20:50:42.000000000 +0100
+@@ -74,126 +74,6 @@
+ # Checks for libraries.
+ dnl Checks for Berkeley DB
+ AC_MSG_CHECKING(for Berkeley DB)
+-AC_ARG_WITH(db,
+-[ --with-db=DIR Use Berkeley DB in DIR],
+-[DBINC=NO
+- DBLIB=NO
+- DBHDR=NO
+- S=1
+- case "$withval" in
+- yes|no)
+- AC_ERROR(Berkeley DB was not found. Please check your installation or use --with-db=PATH)
+- ;;
+- *)
+- AC_MSG_RESULT($withval)
+- if test x${withval} = x ; then
+- withval=/tmp
+- fi
+- if test $S -a -r ${withval}/build_unix/db4.h -a \
+- -r "`ls ${withval}/build_unix/.libs/libdb-4.*.a 2>/dev/null | tail -1`"; then
+- DBINC=-I`echo ${withval}/build_unix/`
+- DBLIB=`ls ${withval}/build_unix/.libs/libdb-4.*.a 2>/dev/null | tail -1`
+- DBHDR="db4.h"
+- grep 'DB_VERSION_MAJOR 4$' ${withval}/build_unix/db4.h >/dev/null 2>&1
+- S=$?
+- fi
+- if test $S -a -r ${withval}/build_unix/db.h -a \
+- -r "`ls ${withval}/build_unix/.libs/libdb-4.*.a 2>/dev/null | tail -1`"; then
+- DBINC=-I`echo ${withval}/build_unix`
+- DBLIB=`ls ${withval}/build_unix/.libs/libdb-4.*.a 2>/dev/null | tail -1`
+- DBHDR="db.h"
+- grep 'DB_VERSION_MAJOR 4$' ${withval}/build_unix/db.h >/dev/null 2>&1
+- S=$?
+- fi
+- if test $S -a -r ${withval}/include/db4/db.h -a \
+- -r ${withval}/lib/db4/libdb.a ; then
+- DBINC="-I${withval}/include/db4"
+- DBLIB="-L${withval}/lib/db4 -ldb"
+- DBHDR="db.h"
+- grep 'DB_VERSION_MAJOR 4$' ${withval}/include/db4/db.h >/dev/null 2>&1
+- S=$?
+- fi
+- if test $S -a -r ${withval}/include/db4.h -a \
+- -r ${withval}/lib/libdb.a ; then
+- DBINC="-I${withval}/include"
+- DBLIB="-L${withval}/lib -ldb"
+- DBHDR="db4.h"
+- grep 'DB_VERSION_MAJOR 4$' ${withval}/include/db4.h >/dev/null 2>&1
+- S=$?
+- fi
+- if test $S -a -r ${withval}/include/db.h -a \
+- -r ${withval}/lib/libdb.a ; then
+- DBINC="-I${withval}/include"
+- DBLIB="-L${withval}/lib -ldb"
+- DBHDR="db.h"
+- grep 'DB_VERSION_MAJOR 4$' ${withval}/include/db.h >/dev/null 2>&1
+- S=$?
+- fi
+- if test $S -eq 1 ; then
+- AC_ERROR(Berkeley DB was not found. Please check your installation or use --with-db=DIR)
+- fi
+- AC_MSG_RESULT(yes)
+- esac ],
+-[DBINC=NO
+- DBLIB=NO
+- DBHDR=NO
+- S=1
+-
+- if test $S -a -r /usr/local/include/db4.h -a \
+- -r /usr/local/lib/libdb.a ; then
+- DBINC="-I/usr/local/include"
+- DBLIB="-L/usr/local/lib -ldb"
+- DBHDR="db4.h"
+- grep 'DB_VERSION_MAJOR 4$' /usr/local/include/db4.h >/dev/null 2>&1
+- S=$?
+- fi
+- if test $S -a -r /usr/local/include/db.h -a \
+- -r /usr/local/lib/libdb.a ; then
+- DBINC="-I/usr/local/include"
+- DBLIB="-L/usr/local/lib -ldb"
+- DBHDR="db.h"
+- grep 'DB_VERSION_MAJOR 4$' /usr/local/include/db.h >/dev/null 2>&1
+- S=$?
+- fi
+- if test $S -a -r /usr/include/db4.h -a \
+- -r /usr/lib/libdb.a ; then
+- DBINC=""
+- DBLIB="-L/usr/lib -ldb"
+- DBHDR="db4.h"
+- grep 'DB_VERSION_MAJOR 4$' /usr/include/db4.h >/dev/null 2>&1
+- S=$?
+- fi
+- if test $S -a -r /usr/include/db.h -a \
+- -r /usr/lib/libdb.a ; then
+- DBINC=""
+- DBLIB="-L/usr/lib -ldb"
+- DBHDR="db.h"
+- grep 'DB_VERSION_MAJOR 4$' /usr/include/db.h >/dev/null 2>&1
+- S=$?
+- fi
+- DIR=`ls -d ../db-4.*/. 2>/dev/null | tail -1`
+- if test $S -a -r ${DIR}/build_unix/db4.h -a \
+- -r "`ls ${DIR}/build_unix/.libs/libdb-4.*.a 2>/dev/null | tail -1`"; then
+- DBINC=-I`echo ${DIR}/build_unix/`
+- DBLIB=`ls ${DIR}/build_unix/.libs/libdb-4.*.a 2>/dev/null | tail -1`
+- DBHDR="db4.h"
+- grep 'DB_VERSION_MAJOR 4$' ${DIR}/build_unix/db4.h >/dev/null 2>&1
+- S=$?
+- fi
+- if test $S -a -r ${DIR}/build_unix/db.h -a \
+- -r "`ls ${DIR}/build_unix/.libs/libdb-4.*.a 2>/dev/null | tail -1`"; then
+- DBINC=-I`echo ${DIR}/build_unix`
+- DBLIB=`ls ${DIR}/build_unix/.libs/libdb-4.*.a 2>/dev/null | tail -1`
+- DBHDR="db.h"
+- grep 'DB_VERSION_MAJOR 4$' ${DIR}/build_unix/db.h >/dev/null 2>&1
+- S=$?
+- fi
+-
+- if test $S -eq 1 ; then
+- AC_ERROR(Berkeley DB was not found. Please check your installation or use --with-db=DIR)
+- fi
+- AC_MSG_RESULT(yes) ]
+-)
+ AC_SUBST(DBINC)
+ AC_SUBST(DBLIB)
+ AC_SUBST(DBHDR)
diff --git a/security/pks/files/pkg-message.in b/security/pks/files/pkg-message.in
index 7e72db0ec54f..5726e54df7b6 100644
--- a/security/pks/files/pkg-message.in
+++ b/security/pks/files/pkg-message.in
@@ -6,6 +6,6 @@
web interface please edit the
configuration file at:
- %%PREFIX%%/etc/pks/pksd.conf
+ %%PREFIX%%/etc/pksd.conf
##################################
diff --git a/security/pks/pkg-plist b/security/pks/pkg-plist
index b81ba6ea7a9a..02f8a7ae7ada 100644
--- a/security/pks/pkg-plist
+++ b/security/pks/pkg-plist
@@ -6,6 +6,8 @@ sbin/pksd
bin/pksdctl
etc/pksd.conf.sample
%%DATADIR%%/mail_intro
+%%DATADIR%%/pks-commands.html
+%%DATADIR%%/pks-commands.php
%%PORTDOCS%%%%DOCSDIR%%/mail_intro
%%PORTDOCS%%%%DOCSDIR%%/pks_help.en
%%PORTDOCS%%%%DOCSDIR%%/pks_help.es