aboutsummaryrefslogtreecommitdiff
path: root/security/poc
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2002-08-01 14:09:29 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2002-08-01 14:09:29 +0000
commit6addcc154f7e220a1316c91163c7735cab5b8c45 (patch)
tree9f875b368d2a5a29103f21ecde767a95329f010e /security/poc
parent7ef4fd636aaf4e7e7a79982b4740f88b21722b27 (diff)
downloadports-6addcc154f7e220a1316c91163c7735cab5b8c45.tar.gz
ports-6addcc154f7e220a1316c91163c7735cab5b8c45.zip
Notes
Diffstat (limited to 'security/poc')
-rw-r--r--security/poc/Makefile12
-rw-r--r--security/poc/files/patch-aa11
-rw-r--r--security/poc/files/patch-src_Makefile.am12
-rw-r--r--security/poc/files/patch-src_missing__libs.h14
4 files changed, 32 insertions, 17 deletions
diff --git a/security/poc/Makefile b/security/poc/Makefile
index 98a8e4142705..ee70a1281c91 100644
--- a/security/poc/Makefile
+++ b/security/poc/Makefile
@@ -13,12 +13,12 @@ MASTER_SITE_SUBDIR=poc
MAINTAINER= king@v2project.com
-LIB_DEPENDS= towitoko.2:${PORTSDIR}/devel/towitoko
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ towitoko.2:${PORTSDIR}/devel/towitoko
-USE_GMAKE= YES
-GNU_CONFIGURE= YES
-
-CONFIGURE_ENV+=CPPFLAGS=-I${LOCALBASE}/include CFLAGS=-I${LOCALBASE}/include \
- LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+USE_AUTOMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ LIBS="-lgnugetopt"
.include <bsd.port.mk>
diff --git a/security/poc/files/patch-aa b/security/poc/files/patch-aa
deleted file mode 100644
index ef4f73989e62..000000000000
--- a/security/poc/files/patch-aa
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Tue Jun 11 22:28:46 2002
-+++ src/Makefile.in Tue Jun 11 22:29:07 2002
-@@ -93,7 +93,7 @@
-
- # debugging
- #CFLAGS = -g -Wall
--CFLAGS = -Wall -O2
-+CFLAGS = -Wall -O2 -I/usr/local/include -L/usr/local/lib
- CPPFLAGS =
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
diff --git a/security/poc/files/patch-src_Makefile.am b/security/poc/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..24959c9bcc62
--- /dev/null
+++ b/security/poc/files/patch-src_Makefile.am
@@ -0,0 +1,12 @@
+
+$FreeBSD$
+
+--- src/Makefile.am.orig Thu Jul 25 16:35:09 2002
++++ src/Makefile.am Thu Jul 25 16:35:18 2002
+@@ -30,6 +30,4 @@
+
+ # debugging
+ #CFLAGS = -g -Wall
+-CFLAGS = -Wall -O2
+-CPPFLAGS =
+
diff --git a/security/poc/files/patch-src_missing__libs.h b/security/poc/files/patch-src_missing__libs.h
new file mode 100644
index 000000000000..0dcf40832e8d
--- /dev/null
+++ b/security/poc/files/patch-src_missing__libs.h
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/missing_libs.h.orig Thu Jul 25 17:11:57 2002
++++ src/missing_libs.h Thu Jul 25 17:12:25 2002
+@@ -46,7 +46,7 @@
+ #define __bswap_constant_16(x) \
+ ((((x) >> 8) & 0xff) | (((x) & 0xff) << 8))
+
+-#if defined __GNUC__ && __GNUC__ >= 2
++#if defined __i386__ && defined __GNUC__ && __GNUC__ >= 2
+ # define __bswap_16(x) \
+ (__extension__ \
+ ({ register unsigned short int __v; \