aboutsummaryrefslogtreecommitdiff
path: root/security/polarssl/Makefile
diff options
context:
space:
mode:
authorJase Thew <jase@FreeBSD.org>2012-11-26 19:49:22 +0000
committerJase Thew <jase@FreeBSD.org>2012-11-26 19:49:22 +0000
commit70dc19873fac1f58c5c5be0f42803641af02b55f (patch)
tree50f8ffa935255c2a445ce514ea372fb76a6d6f9b /security/polarssl/Makefile
parentfbdcc0802caa576c3ed1c559db37f728c59197d7 (diff)
Notes
Diffstat (limited to 'security/polarssl/Makefile')
-rw-r--r--security/polarssl/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/security/polarssl/Makefile b/security/polarssl/Makefile
index dad667ead5ab..46fd6a60b511 100644
--- a/security/polarssl/Makefile
+++ b/security/polarssl/Makefile
@@ -1,18 +1,21 @@
# $FreeBSD$
PORTNAME= polarssl
-PORTVERSION= 1.1.4
+PORTVERSION= 1.2.3
DISTVERSIONSUFFIX= -gpl
CATEGORIES= security devel
-MASTER_SITES= http://polarssl.org/code/download/
+MASTER_SITES= http://polarssl.org/download/
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= jase@FreeBSD.org
COMMENT= Open Source embedded SSL/TLS cryptographic library
LICENSE= GPLv2
-USE_PERL5_BUILD= yes
+FETCH_ARGS= -pRr
+ALL_TARGET= no_test
+
+USE_GMAKE= yes
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
@@ -33,8 +36,10 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${PREFIX}/bin/polarssl_${i}
.endfor
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for i in ${PORTDOCS}
${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}/