aboutsummaryrefslogtreecommitdiff
path: root/security/polarssl
diff options
context:
space:
mode:
authorJase Thew <jase@FreeBSD.org>2013-09-30 22:38:41 +0000
committerJase Thew <jase@FreeBSD.org>2013-09-30 22:38:41 +0000
commit8427671fd74f8295f94dafc26be11deb21a50c52 (patch)
treea8e3a616314a53437a9d7c331e6649e4c11df1ae /security/polarssl
parent9eeb431890162201302c372ff3e6ab54853913ba (diff)
downloadports-8427671fd74f8295f94dafc26be11deb21a50c52.tar.gz
ports-8427671fd74f8295f94dafc26be11deb21a50c52.zip
Notes
Diffstat (limited to 'security/polarssl')
-rw-r--r--security/polarssl/Makefile22
-rw-r--r--security/polarssl/files/patch-include-polarssl-config_h12
-rw-r--r--security/polarssl/pkg-plist5
3 files changed, 27 insertions, 12 deletions
diff --git a/security/polarssl/Makefile b/security/polarssl/Makefile
index 025dc2bb79b4..e552e8c6cf1b 100644
--- a/security/polarssl/Makefile
+++ b/security/polarssl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= polarssl
PORTVERSION= 1.2.8
DISTVERSIONSUFFIX= -gpl
+PORTREVISION= 1
CATEGORIES= security devel
MASTER_SITES= http://polarssl.org/download/
EXTRACT_SUFX= .tgz
@@ -18,35 +19,34 @@ URL_SUFFIX= ?do=yes
FETCH_ARGS= -pRro ${DISTFILES}
ALL_TARGET= no_test
-USE_GMAKE= yes
+USES= gmake
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-PORTDOCS= ChangeLog README
+DOCFILES= ChangeLog README
BINFILES= aescrypt2 benchmark dh_client dh_genprime dh_server hello \
md5sum mpi_demo rsa_genkey rsa_sign rsa_verify selftest \
sha1sum sha2sum ssl_cert_test ssl_client1 ssl_client2 \
ssl_server ssl_test
# cmake install is broken, so we do it by hand
-NO_STAGE= yes
do-install:
- @${TAR} -C ${WRKSRC}/include -cf - polarssl | ${TAR} -C ${PREFIX}/include -xf -
- ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.a ${PREFIX}/lib/
- ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.so ${PREFIX}/lib/libpolarssl.so.0
- cd ${PREFIX}/lib/ && ${LN} -sf libpolarssl.so.0 libpolarssl.so
+ @${TAR} -C ${WRKSRC}/include -cf - polarssl | ${TAR} -C ${STAGEDIR}${PREFIX}/include -xf -
+ ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.a ${STAGEDIR}${PREFIX}/lib/
+ ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.so ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.0
+ cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libpolarssl.so.0 libpolarssl.so
.for i in ${BINFILES}
- ${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${PREFIX}/bin/polarssl_${i}
+ ${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${STAGEDIR}${PREFIX}/bin/polarssl_${i}
.endfor
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
-.for i in ${PORTDOCS}
- ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}/
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for i in ${DOCFILES}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/security/polarssl/files/patch-include-polarssl-config_h b/security/polarssl/files/patch-include-polarssl-config_h
new file mode 100644
index 000000000000..66aaf433c73c
--- /dev/null
+++ b/security/polarssl/files/patch-include-polarssl-config_h
@@ -0,0 +1,12 @@
+--- include/polarssl/config.h.orig 2013-09-24 16:37:14.000000000 +0200
++++ include/polarssl/config.h 2013-09-24 16:39:22.000000000 +0200
+@@ -627,8 +627,8 @@
+ * Requires: POLARSSL_TIMING_C
+ *
+ * Uncomment to enable the HAVEGE random generator.
+-#define POLARSSL_HAVEGE_C
+ */
++#define POLARSSL_HAVEGE_C
+
+ /**
+ * \def POLARSSL_MD_C
diff --git a/security/polarssl/pkg-plist b/security/polarssl/pkg-plist
index bec721363449..d0f84fc4408b 100644
--- a/security/polarssl/pkg-plist
+++ b/security/polarssl/pkg-plist
@@ -66,4 +66,7 @@ include/polarssl/xtea.h
lib/libpolarssl.a
lib/libpolarssl.so
lib/libpolarssl.so.0
-@dirrm include/polarssl
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrmtry include/polarssl