aboutsummaryrefslogtreecommitdiff
path: root/security/pond/Makefile
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2015-12-31 21:04:13 +0000
committerCarlo Strub <cs@FreeBSD.org>2015-12-31 21:04:13 +0000
commit875e0fa5b489c7f34c0f56c8b658a7e1302a7997 (patch)
treeaa4161abff614842d3b6b1ce1c05f72961516dd2 /security/pond/Makefile
parentb4166e17df965e44bb7e8a1b251f892379cce841 (diff)
Notes
Diffstat (limited to 'security/pond/Makefile')
-rw-r--r--security/pond/Makefile54
1 files changed, 35 insertions, 19 deletions
diff --git a/security/pond/Makefile b/security/pond/Makefile
index 5ea0d5f6879f..be0c82da8c34 100644
--- a/security/pond/Makefile
+++ b/security/pond/Makefile
@@ -1,13 +1,12 @@
# $FreeBSD$
PORTNAME= pond
-PORTVERSION= 20140824
-PORTREVISION= 2
+PORTVERSION= 20150830
CATEGORIES= security
MASTER_SITES= http://c-s.li/ports/
-DISTFILES= pond-20140824.tar.gz \
- go-gtk-20140629.tar.gz \
- ed25519-20140215.tar.gz
+DISTFILES= pond-20150830.tar.gz \
+ go-gtk-20151214.tar.gz \
+ ed25519-20150830.tar.gz
MAINTAINER= cs@FreeBSD.org
COMMENT= Forward secure, asynchronous messenger
@@ -32,28 +31,45 @@ post-extract:
@${LN} -sf ${WRKSRC} ${GO_WRKSRC}
@${LN} -sf ${WRKSRC}/client ${WRKSRC}/pond
@${LN} -sf ${WRKSRC}/server ${WRKSRC}/pond-server
- @${LN} -sf ${WRKDIR}/go-gtk-20140629 ${GO_WRKDIR_SRC}/github.com/agl/go-gtk
- @${LN} -sf ${WRKDIR}/ed25519-20140215 ${GO_WRKDIR_SRC}/github.com/agl/ed25519
+ @${LN} -sf ${WRKDIR}/go-gtk-20151214 ${GO_WRKDIR_SRC}/github.com/agl/go-gtk
+ @${LN} -sf ${WRKDIR}/ed25519-20150830 ${GO_WRKDIR_SRC}/github.com/agl/ed25519
post-patch:
@${REINPLACE_CMD} -e 's|\<gdk|\<gtk-3.0\/gdk|g' \
- ${WRKDIR}/go-gtk-20140629/gdk/gdk.go \
- ${WRKDIR}/go-gtk-20140629/gdk/gdk_linux.go \
- ${WRKDIR}/go-gtk-20140629/gdk/gdk_windows.go \
- ${WRKDIR}/go-gtk-20140629/gtk/gtk.go
+ ${WRKDIR}/go-gtk-20151214/gdk/gdk.go \
+ ${WRKDIR}/go-gtk-20151214/gdk/gdk_linux.go \
+ ${WRKDIR}/go-gtk-20151214/gdk/gdk_windows.go \
+ ${WRKDIR}/go-gtk-20151214/gtk/gtk.go
@${REINPLACE_CMD} -e 's|\<pango|\<pango-1.0\/pango|g' \
- ${WRKDIR}/go-gtk-20140629/pango/pango.go
+ ${WRKDIR}/go-gtk-20151214/pango/pango.go
@${REINPLACE_CMD} -e 's|\<gtk|\<gtk-3.0\/gtk|g' \
- ${WRKDIR}/go-gtk-20140629/gtk/gtk.go \
- ${WRKDIR}/go-gtk-20140629/gtkspell/gtkspell_fedora.go \
- ${WRKDIR}/go-gtk-20140629/gtkspell/gtkspell_ubuntu.go
+ ${WRKDIR}/go-gtk-20151214/gtk/gtk.go \
+ ${WRKDIR}/go-gtk-20151214/gtkspell/gtkspell_fedora.go \
+ ${WRKDIR}/go-gtk-20151214/gtkspell/gtkspell_ubuntu.go
@${REINPLACE_CMD} -e 's|\<glib|\<glib-2.0\/glib|g' \
- ${WRKDIR}/go-gtk-20140629/glib/glib.go
+ ${WRKDIR}/go-gtk-20151214/glib/glib.go
@${REINPLACE_CMD} -e 's|\<gdk-pixbuf|\<gdk-pixbuf-2.0\/gdk-pixbuf|g' \
- ${WRKDIR}/go-gtk-20140629/gdkpixbuf/gdkpixbuf.go
+ ${WRKDIR}/go-gtk-20151214/gdkpixbuf/gdkpixbuf.go
@${REINPLACE_CMD} -e 's|\<gtkspell|\<gtkspell-2.0\/gtkspell|g' \
- ${WRKDIR}/go-gtk-20140629/gtkspell/gtkspell_fedora.go \
- ${WRKDIR}/go-gtk-20140629/gtkspell/gtkspell_ubuntu.go
+ ${WRKDIR}/go-gtk-20151214/gtkspell/gtkspell_fedora.go \
+ ${WRKDIR}/go-gtk-20151214/gtkspell/gtkspell_ubuntu.go
+ @${REINPLACE_CMD} -e 's|golang.org\/x\/crypto|code.google.com\/p\/go.crypto|g' \
+ ${WRKDIR}/pond-20150830/bbssig/bbssig.go \
+ ${WRKDIR}/pond-20150830/transport/transport.go \
+ ${WRKDIR}/pond-20150830/pond-server/main.go \
+ ${WRKDIR}/pond-20150830/protos/const.go \
+ ${WRKDIR}/pond-20150830/client/ratchet/ratchet.go \
+ ${WRKDIR}/pond-20150830/panda/panda.go \
+ ${WRKDIR}/pond-20150830/pond/client.go \
+ ${WRKDIR}/pond-20150830/pond/disk.go \
+ ${WRKDIR}/pond-20150830/pond/network.go \
+ ${WRKDIR}/pond-20150830/client/disk/disk.go \
+ ${WRKDIR}/pond-20150830/pond/background.go \
+ ${WRKDIR}/pond-20150830/pond/cli-input.go \
+ ${WRKDIR}/pond-20150830/pond/cli.go
+ @${REINPLACE_CMD} -e 's|golang.org/x/net|code.google.com\/p\/go.net|g' \
+ ${WRKDIR}/pond-20150830/panda/appengine.go \
+ ${WRKDIR}/pond-20150830/pond/network.go
do-build:
@(cd ${GO_WRKSRC}; ${SETENV} ${GO_ENV} ${GO_CMD} install -tags nogui -v ${GO_TARGET})