aboutsummaryrefslogtreecommitdiff
path: root/security/ppars/Makefile
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2005-02-07 14:53:28 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2005-02-07 14:53:28 +0000
commit51fdd4cbc974b0c2ccb49eab77894e0514d77e80 (patch)
tree11a88b2727c7697ec496e5a47e27b102af94d53c /security/ppars/Makefile
parentd637d2c31f0abe5afce572c57839012028c4ad1f (diff)
downloadports-51fdd4cbc974b0c2ccb49eab77894e0514d77e80.tar.gz
ports-51fdd4cbc974b0c2ccb49eab77894e0514d77e80.zip
Notes
Diffstat (limited to 'security/ppars/Makefile')
-rw-r--r--security/ppars/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/security/ppars/Makefile b/security/ppars/Makefile
new file mode 100644
index 000000000000..893cca121dfc
--- /dev/null
+++ b/security/ppars/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: ppars
+# Date created: 2004-06-29
+# Whom: Joe Barbish <fbsd_user@a1poweruser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ppars
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://www.dshield.org/clients/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= fbsd_user@a1poweruser.com
+COMMENT= Proactive Probing Abuse Reporting System
+
+RUN_DEPENDS= ${SITE_PERL}/Net/Netmask.pm:${PORTSDIR}/net-mgmt/p5-Net-Netmask
+
+USE_PERL5= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+SUB_FILES= pkg-message
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 490000
+IGNORE= "Not supported on releases prior to 4.9"
+.endif
+
+do-install:
+ @${MKDIR} ${PREFIX}/sbin
+ ${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${PREFIX}/sbin
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>