aboutsummaryrefslogtreecommitdiff
path: root/security/prelude-lml
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-21 11:50:53 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-21 11:50:53 +0000
commit640cca1ddc62764a1315f4d5e9cb8d0f52dd0767 (patch)
tree9a19cf0f0f53ec5b37560d6d348f05a1991afeaf /security/prelude-lml
parent93631851fd24f2e1a257bb0ed55fecdb511f32dc (diff)
downloadports-640cca1ddc62764a1315f4d5e9cb8d0f52dd0767.tar.gz
ports-640cca1ddc62764a1315f4d5e9cb8d0f52dd0767.zip
Notes
Diffstat (limited to 'security/prelude-lml')
-rw-r--r--security/prelude-lml/Makefile5
-rw-r--r--security/prelude-lml/distinfo9
-rw-r--r--security/prelude-lml/files/prelude-lml.sh.in27
3 files changed, 33 insertions, 8 deletions
diff --git a/security/prelude-lml/Makefile b/security/prelude-lml/Makefile
index df0d05a441fc..84a6a09e5243 100644
--- a/security/prelude-lml/Makefile
+++ b/security/prelude-lml/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= prelude-lml
-PORTVERSION= 0.9.3
+PORTVERSION= 0.9.4
CATEGORIES= security
MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
http://www.prelude-ids.org/download/releases/old/
@@ -13,13 +13,14 @@ MASTER_SITES= http://www.prelude-ids.org/download/releases/ \
MAINTAINER= r.gruyters@yirdis.nl
COMMENT= Prelude Network Intrusion Detection System Log Monitoring Lackey
-LIB_DEPENDS+= prelude.6:${PORTSDIR}/security/libprelude \
+LIB_DEPENDS+= prelude.7:${PORTSDIR}/security/libprelude \
pcre.0:${PORTSDIR}/devel/pcre
USE_GPG= yes
SIG_SUFFIX= .sig
USE_GMAKE= yes
GNU_CONFIGURE= yes
+USE_RC_SUBR= prelude-lml.sh
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --with-html-dir=${PREFIX}/share/doc
diff --git a/security/prelude-lml/distinfo b/security/prelude-lml/distinfo
index ad78f8e1876f..3b53b38c9610 100644
--- a/security/prelude-lml/distinfo
+++ b/security/prelude-lml/distinfo
@@ -1,6 +1,3 @@
-MD5 (prelude-lml-0.9.3.tar.gz) = 514115e4e4e4197bc68808e489c367f3
-SHA256 (prelude-lml-0.9.3.tar.gz) = f22ef7920393fd0bdae641be7050255d1f070174c589b7e8d3ca8d02fc135386
-SIZE (prelude-lml-0.9.3.tar.gz) = 536431
-MD5 (prelude-lml-0.9.3.tar.gz.sig) = 829dbb9702853fe6d36e4299a84838e8
-SHA256 (prelude-lml-0.9.3.tar.gz.sig) = e9a55a55fcf7061b260fc0295db09a3a3c9ac65e9cce4e4e80e0f1c91abb853d
-SIZE (prelude-lml-0.9.3.tar.gz.sig) = 829
+MD5 (prelude-lml-0.9.4.tar.gz) = 33ed8f9428df64778041e4d8fe41c479
+SHA256 (prelude-lml-0.9.4.tar.gz) = 28d64d42f3a454fafad3ac974e76d2cd83183881453b2dfc69f3c0ad955b76aa
+SIZE (prelude-lml-0.9.4.tar.gz) = 537936
diff --git a/security/prelude-lml/files/prelude-lml.sh.in b/security/prelude-lml/files/prelude-lml.sh.in
new file mode 100644
index 000000000000..252be5d71e4a
--- /dev/null
+++ b/security/prelude-lml/files/prelude-lml.sh.in
@@ -0,0 +1,27 @@
+#!/bin/sh
+
+# PROVIDE: prelude_lml
+# REQUIRE: NETWORKING SERVERS
+#
+# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
+# to enable this service:
+#
+# prelude_lml_enable (bool): Set to NO by default.
+# Set it to YES to enable Prelude LML.
+# prelude_lml_flags (flags): Set arguments to use with Prelude LML
+#
+
+. %%RC_SUBR%%
+
+name="prelude_lml"
+rcvar=${name}_enable
+
+command=%%PREFIX%%/bin/prelude-lml
+pidfile=/var/run/prelude-lml.pid
+
+load_rc_config $name
+
+: ${prelude_lml_enable="NO"}
+: ${prelude_lml_flags:-"-d -P ${pidfile}"}
+
+run_rc_command "$1"