aboutsummaryrefslogtreecommitdiff
path: root/security/protonvpn-cli
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2019-10-07 14:48:42 +0000
committerSteve Wills <swills@FreeBSD.org>2019-10-07 14:48:42 +0000
commita214877d350f1e96d95e3cb839a79628a605028a (patch)
tree06001bf4f2cc37dbaa6307fa260e5cae1e66b7b9 /security/protonvpn-cli
parentc86a2c9b1f97060806aa29085f5e1891257608c4 (diff)
security/protonvpn-cli: fixes issue with certs and issue with countries
PR: 241103 Submitted by: Lorenzo Salvadore <phascolarctos@protonmail.ch> (maintainer)
Notes
Notes: svn path=/head/; revision=513952
Diffstat (limited to 'security/protonvpn-cli')
-rw-r--r--security/protonvpn-cli/Makefile6
-rw-r--r--security/protonvpn-cli/files/patch-protonvpn-cli.sh4
2 files changed, 6 insertions, 4 deletions
diff --git a/security/protonvpn-cli/Makefile b/security/protonvpn-cli/Makefile
index 05aa1f745ff0..926183dab508 100644
--- a/security/protonvpn-cli/Makefile
+++ b/security/protonvpn-cli/Makefile
@@ -3,6 +3,7 @@
PORTNAME= protonvpn-cli
DISTVERSIONPREFIX= v
DISTVERSION= 1.1.2
+PORTREVISION= 1
CATEGORIES= security net net-vpn
MAINTAINER= phascolarctos@protonmail.ch
@@ -16,7 +17,8 @@ LICENSE_DISTFILES_GPLv3= ${DISTFILES:M*scripts*}
RUN_DEPENDS= bash:shells/bash \
openvpn:security/openvpn \
- wget:ftp/wget
+ wget:ftp/wget \
+ ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
USES= python
@@ -34,7 +36,7 @@ PLIST_FILES= bin/protonvpn-cli \
post-patch:
${REINPLACE_CMD} s,\$$python,${PYTHON_CMD},g ${WRKSRC}/protonvpn-cli.sh
- ${REINPLACE_CMD} s,wget,wget\ --no-check-certificate,g ${WRKSRC}/protonvpn-cli.sh
+ ${REINPLACE_CMD} s,wget,wget\ --ca-certificate\ ${LOCALBASE}/share/certs/ca-root-nss.crt,g ${WRKSRC}/protonvpn-cli.sh
${REINPLACE_CMD} s,%%LOCALBASE%%,${LOCALBASE},g ${WRKSRC}/protonvpn-cli.sh
do-install:
diff --git a/security/protonvpn-cli/files/patch-protonvpn-cli.sh b/security/protonvpn-cli/files/patch-protonvpn-cli.sh
index 589599ef885d..0bbe7e75e18c 100644
--- a/security/protonvpn-cli/files/patch-protonvpn-cli.sh
+++ b/security/protonvpn-cli/files/patch-protonvpn-cli.sh
@@ -229,10 +229,10 @@
+ then
+ if [[ $1 -eq 1 ]]
+ then
-+ country_id=6
++ country_id=9
+ elif [[ $1 -eq 2 ]]
+ then
-+ country_id=7
++ country_id=6
+ fi
+ fi
+