aboutsummaryrefslogtreecommitdiff
path: root/security/pulledpork
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-03-10 20:46:26 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-03-10 20:46:26 +0000
commit20458e371512be7399d979125db88533a2cbfa26 (patch)
tree9fdaa7b149ccc871309ba7c46bdd147595321869 /security/pulledpork
parentdfb1957da2b45131c7b89e8adee44b342c3feb28 (diff)
downloadports-20458e371512be7399d979125db88533a2cbfa26.tar.gz
ports-20458e371512be7399d979125db88533a2cbfa26.zip
Notes
Diffstat (limited to 'security/pulledpork')
-rw-r--r--security/pulledpork/Makefile21
1 files changed, 10 insertions, 11 deletions
diff --git a/security/pulledpork/Makefile b/security/pulledpork/Makefile
index 32682aacbdb8..a68176ee6e5b 100644
--- a/security/pulledpork/Makefile
+++ b/security/pulledpork/Makefile
@@ -7,22 +7,24 @@
PORTNAME= pulledpork
PORTVERSION= 0.6.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
MAINTAINER= ohauer@FreeBSD.org
COMMENT= Script to update snort-2.8+ rules
+LICENSE= GPLv2
+
RUN_DEPENDS= p5-Crypt-SSLeay>=0.57:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-LWP-Protocol-https>=6.00:${PORTSDIR}/www/p5-LWP-Protocol-https \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-LICENSE= GPLv2
-
NO_BUILD= yes
USE_PERL5_RUN= yes
-PLIST_DIRS= %%ETCDIR%% \
- %%DATADIR%%
+PLIST_DIRSTRY= %%ETCDIR%%
+PLIST_DIRS= %%DATADIR%%
PLIST_FILES= bin/pulledpork.pl \
%%ETCDIR%%/disablesid.conf.sample \
@@ -35,12 +37,6 @@ PLIST_FILES= bin/pulledpork.pl \
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
-
-.if (${PERL_LEVEL} < 501000)
-RUN_DEPENDS+= p5-Archive-Tar>=1.52:${PORTSDIR}/archivers/p5-Archive-Tar
-.endif
-
.if !defined(NOPORTDOCS)
PORTDOCS= LICENSE README README.CATEGORIES README.CHANGES README.RULESET README.SHAREDOBJECTS
.endif
@@ -54,6 +50,9 @@ post-patch:
-e "s|/usr/local/lib/snort_dynamicrules/|${PREFIX}/etc/snort/so_rules/|g" \
${WRKSRC}/etc/pulledpork.conf
@${REINPLACE_CMD} -e "s| /usr/bin/perl|${PERL}|" ${WRKSRC}/contrib/oink-conv.pl
+# pulledpork bug id:110
+ @${REINPLACE_CMD} -e 's|distro=FreeBSD-8.0|distro=FreeBSD-8-1|g' \
+ ${WRKSRC}/etc/pulledpork.conf
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/pulledpork.pl ${PREFIX}/bin
@@ -80,4 +79,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>