aboutsummaryrefslogtreecommitdiff
path: root/security/pure-sfv
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-07-26 17:08:48 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-07-26 17:08:48 +0000
commitb69d7949c9873075068d70a3880221e2e293ab41 (patch)
tree0f6070ebab86a629fe05dd37fb7cc482a7af0ee4 /security/pure-sfv
parent7488d427d1b4db0954ad5b76805255cc86086477 (diff)
downloadports-b69d7949c9873075068d70a3880221e2e293ab41.tar.gz
ports-b69d7949c9873075068d70a3880221e2e293ab41.zip
Notes
Diffstat (limited to 'security/pure-sfv')
-rw-r--r--security/pure-sfv/Makefile37
-rw-r--r--security/pure-sfv/distinfo2
-rw-r--r--security/pure-sfv/pkg-descr16
3 files changed, 55 insertions, 0 deletions
diff --git a/security/pure-sfv/Makefile b/security/pure-sfv/Makefile
new file mode 100644
index 000000000000..a32456899e5d
--- /dev/null
+++ b/security/pure-sfv/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: pure-sfv
+# Date created: 26 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pure-sfv
+PORTVERSION= 0.3
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION}_src
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Utility to test and create .sfv files
+
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+WRKSRC= ${WRKDIR}
+PLIST_FILES= bin/pure-sfv
+PORTDOCS= ReadMe.txt
+
+post-patch:
+ @${REINPLACE_CMD} -E 's/^(CFLAGS|CC)[ +=]*/\1?=/' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/pure-sfv/distinfo b/security/pure-sfv/distinfo
new file mode 100644
index 000000000000..a0faed7e6a08
--- /dev/null
+++ b/security/pure-sfv/distinfo
@@ -0,0 +1,2 @@
+MD5 (pure-sfv_0.3_src.tar.gz) = 2643118c32184c880cd8935173889449
+SIZE (pure-sfv_0.3_src.tar.gz) = 79069
diff --git a/security/pure-sfv/pkg-descr b/security/pure-sfv/pkg-descr
new file mode 100644
index 000000000000..f04f753b3520
--- /dev/null
+++ b/security/pure-sfv/pkg-descr
@@ -0,0 +1,16 @@
+This utility creates .SFV (Simple File Verify) and .PAR (Parity Archive) data
+files.
+
+Features:
+
+ * Recursive directories handling
+ * Automatic checksum file naming ability in create mode
+ * Meaningful and documented exit values for easy scripting
+ * Wildcards for file names
+ * Creation of PAR (Parity Archive) files
+ * Create Multiple recovery sets if number of files in SFV greater than 255
+
+WWW: http://pure-sfv.sourceforge.net/
+
+- ehaupt
+ehaupt@critical.ch