aboutsummaryrefslogtreecommitdiff
path: root/security/putty/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-02-13 17:45:39 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-02-13 17:45:39 +0000
commit4d3b1de9f7c017656fa451909180ea9f04b3e2ff (patch)
tree22e8cdf366d7d34daf0e73cc787307b82f747fb8 /security/putty/Makefile
parentdd53c83aa18a93ac9c287d1d723d52762f949b01 (diff)
downloadports-4d3b1de9f7c017656fa451909180ea9f04b3e2ff.tar.gz
ports-4d3b1de9f7c017656fa451909180ea9f04b3e2ff.zip
Notes
Diffstat (limited to 'security/putty/Makefile')
-rw-r--r--security/putty/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/security/putty/Makefile b/security/putty/Makefile
new file mode 100644
index 000000000000..138eeeacd19c
--- /dev/null
+++ b/security/putty/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: putty
+# Date created: 13 Feb 2004
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= putty
+PORTVERSION= 0.54
+CATEGORIES= security
+MASTER_SITES= http://the.earth.li/~sgtatham/putty/%SUBDIR%/
+MASTER_SITE_SUBDIR= ${PORTVERSION}
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Secure shell and telnet client
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/unix
+MAKEFILE= Makefile.gtk
+CFLAGS+= -DOMIT_UTMP
+CFLAGS= -DBSD_PTYS -DOMIT_UTMP
+
+PLIST_FILES= bin/plink bin/pscp bin/psftp
+MAN1= plink.1
+
+.ifndef WITHOUT_GTK
+USE_GNOME= gtk12
+PLIST_FILES+= bin/pterm bin/putty bin/puttygen bin/puttytel
+MAN1+= pterm.1 putty.1 puttygen.1 puttytel.1
+MAKE_ENV+= PUTTY_WITH_GTK=yes
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+CFLAGS+= -DFREEBSD_MB_SUPPORT
+
+do-configure:
+ ${CP} ${FILESDIR}/wcrtomb.c ${FILESDIR}/mbrtowc.c \
+ ${WRKSRC}/
+.endif
+
+.include <bsd.port.post.mk>