aboutsummaryrefslogtreecommitdiff
path: root/security/putty/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2019-07-20 16:16:42 +0000
committerMatthias Andree <mandree@FreeBSD.org>2019-07-20 16:16:42 +0000
commit04f01be22357f571082556c585cefad68fcbd861 (patch)
treec2b6e9e3d9cb09837b7af1ee08a2b2e707a89672 /security/putty/Makefile
parent7ab9978b709f497e73b7104cfbe28f3d1867beb2 (diff)
downloadports-04f01be22357f571082556c585cefad68fcbd861.tar.gz
ports-04f01be22357f571082556c585cefad68fcbd861.zip
Notes
Diffstat (limited to 'security/putty/Makefile')
-rw-r--r--security/putty/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/security/putty/Makefile b/security/putty/Makefile
index 70a4d5c86f65..6c5c9cb0b19e 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= putty
-PORTVERSION= 0.71
+PORTVERSION= 0.72
CATEGORIES= security ipv6
MASTER_SITES= http://the.earth.li/~sgtatham/putty/${PORTVERSION}/ \
ftp://ftp.chiark.greenend.org.uk/users/sgtatham/putty-latest/
@@ -34,7 +34,7 @@ CONFLICTS_INSTALL?= pssh-[0-9]* putty-gtk2-[0-9]* putty-nogtk-[0-9]*
.include <bsd.port.options.mk>
-CFLAGS+= -DBSD_PTYS -DOMIT_UTMP -DIPV6
+CFLAGS+= -DBSD_PTYS -DOMIT_UTMP -DIPV6 -DHAVE_FUTIMES
LDFLAGS+= -Wl,--as-needed
.if (${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGTK3}) && !defined(WITHOUT_X11)
@@ -64,15 +64,12 @@ MAKE_ARGS+= GTK_CONFIG=:
.endif
.if ${PORT_OPTIONS:MGSSAPI_BASE}
-_COMPAT= -DSTATIC_GSSAPI
USES+= gssapi:base,flags
MAKE_ARGS+= KRB5CONFIG=${KRB5CONFIG}
.elif ${PORT_OPTIONS:MGSSAPI_HEIMDAL}
-_COMPAT= -DSTATIC_GSSAPI
USES+= gssapi:heimdal,flags
MAKE_ARGS+= KRB5CONFIG=${KRB5CONFIG}
.elif ${PORT_OPTIONS:MGSSAPI_MIT}
-_COMPAT= -DSTATIC_GSSAPI
USES+= gssapi:mit,flags
MAKE_ARGS+= KRB5CONFIG=${KRB5CONFIG}
.else