aboutsummaryrefslogtreecommitdiff
path: root/security/putty
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-05-25 12:34:15 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-05-25 12:34:15 +0000
commit78eadaaaa88f7615921b81e7f58ac5cb561c87c9 (patch)
treef5803b05e23cc421e0fbf192504264b5ee4d6a86 /security/putty
parent786d2c25ce9e2e1a268a1b109bc3878d9d7df9b1 (diff)
downloadports-78eadaaaa88f7615921b81e7f58ac5cb561c87c9.tar.gz
ports-78eadaaaa88f7615921b81e7f58ac5cb561c87c9.zip
Notes
Diffstat (limited to 'security/putty')
-rw-r--r--security/putty/Makefile3
-rw-r--r--security/putty/distinfo6
-rw-r--r--security/putty/files/patch-Makefile.gtk20
3 files changed, 14 insertions, 15 deletions
diff --git a/security/putty/Makefile b/security/putty/Makefile
index fbd9dab367ac..01fb91e69e96 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= putty
-PORTVERSION= 0.59
-PORTREVISION= 1
+PORTVERSION= 0.60
CATEGORIES= security ipv6
MASTER_SITES= http://the.earth.li/~sgtatham/putty/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
diff --git a/security/putty/distinfo b/security/putty/distinfo
index 1b7229e40638..b15d64d001de 100644
--- a/security/putty/distinfo
+++ b/security/putty/distinfo
@@ -1,3 +1,3 @@
-MD5 (putty-0.59.tar.gz) = 2c90f3aecd2e4b41df61fb047a6c8f11
-SHA256 (putty-0.59.tar.gz) = 578006f899a9363a7a627fcd362fbfb4b500c3b265c389df2d1ed292a7653bbc
-SIZE (putty-0.59.tar.gz) = 1736071
+MD5 (putty-0.60.tar.gz) = 07e65fd98b16d115ae38a180bfb242e2
+SHA256 (putty-0.60.tar.gz) = b2bbaaf9324997e85cf15d44ed41e8e89539c8215dceac9d6d7272a37dbc2849
+SIZE (putty-0.60.tar.gz) = 1743711
diff --git a/security/putty/files/patch-Makefile.gtk b/security/putty/files/patch-Makefile.gtk
index 1f52d192f3e7..0fb7bef69bea 100644
--- a/security/putty/files/patch-Makefile.gtk
+++ b/security/putty/files/patch-Makefile.gtk
@@ -1,6 +1,6 @@
---- Makefile.gtk.orig Wed Jan 24 18:22:52 2007
-+++ Makefile.gtk Thu Mar 15 13:55:48 2007
-@@ -98,8 +98,8 @@
+--- Makefile.gtk.orig Sun Apr 29 22:41:48 2007
++++ Makefile.gtk Thu May 3 13:52:34 2007
+@@ -99,8 +99,8 @@
# TOOLPATH = /opt/gcc/bin
CC = $(TOOLPATH)cc
@@ -8,10 +8,10 @@
- -I../mac/ -I../macosx/ `gtk-config --cflags` -D _FILE_OFFSET_BITS=64
+CFLAGS += -O2 -Wall -g -I.././ -I../charset/ -I../windows/ -I../unix/ \
+ -I../mac/ -I../macosx/ -D _FILE_OFFSET_BITS=64
- XLDFLAGS = `gtk-config --libs`
- ULDFLAGS =#
+ XLDFLAGS = $(LDFLAGS) `gtk-config --libs`
+ ULDFLAGS = $(LDFLAGS)
INSTALL=install
-@@ -115,7 +115,11 @@
+@@ -116,7 +116,11 @@
.SUFFIXES:
@@ -23,8 +23,8 @@
plink: be_all_s.o cmdline.o cproxy.o ldisc.o logging.o misc.o pinger.o \
portfwd.o proxy.o raw.o rlogin.o settings.o ssh.o sshaes.o \
-@@ -904,7 +908,7 @@
- $(CC) $(COMPAT) $(XFLAGS) $(CFLAGS) -c ../unix/xpmputty.c
+@@ -905,7 +909,7 @@
+ $(CC) $(COMPAT) $(CFLAGS) $(XFLAGS) -c ../unix/xpmputty.c
version.o: FORCE
- if test -z "$(VER)" && (cd ..; md5sum -c manifest); then \
@@ -32,7 +32,7 @@
$(CC) $(COMPAT) $(XFLAGS) $(CFLAGS) `cat ../version.def` -c ../version.c; \
else \
$(CC) $(COMPAT) $(XFLAGS) $(CFLAGS) $(VER) -c ../version.c; \
-@@ -913,6 +917,8 @@
+@@ -914,6 +918,8 @@
$(INSTALL_PROGRAM) -m 755 plink $(DESTDIR)$(bindir)/plink
$(INSTALL_PROGRAM) -m 755 pscp $(DESTDIR)$(bindir)/pscp
$(INSTALL_PROGRAM) -m 755 psftp $(DESTDIR)$(bindir)/psftp
@@ -41,7 +41,7 @@
$(INSTALL_PROGRAM) -m 755 pterm $(DESTDIR)$(bindir)/pterm
if test -n "$(UTMP_GROUP)"; then \
chgrp $(UTMP_GROUP) $(DESTDIR)$(bindir)/pterm && \
-@@ -922,15 +928,17 @@
+@@ -923,15 +929,17 @@
chmod 4755 $(DESTDIR)$(bindir)/pterm; \
fi
$(INSTALL_PROGRAM) -m 755 putty $(DESTDIR)$(bindir)/putty