aboutsummaryrefslogtreecommitdiff
path: root/security/putty
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2004-08-04 08:03:06 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2004-08-04 08:03:06 +0000
commit5ec9b91233ef74af1df621ac1c4efa28741e9b1b (patch)
tree60b2eb7c0447e5dbb514797548dda4bd88948bc5 /security/putty
parentf5e7f3718ecdc8236a277752789ce114bbcf0029 (diff)
downloadports-5ec9b91233ef74af1df621ac1c4efa28741e9b1b.tar.gz
ports-5ec9b91233ef74af1df621ac1c4efa28741e9b1b.zip
Notes
Diffstat (limited to 'security/putty')
-rw-r--r--security/putty/Makefile5
-rw-r--r--security/putty/distinfo4
-rw-r--r--security/putty/files/patch-Makefile.gtk35
3 files changed, 22 insertions, 22 deletions
diff --git a/security/putty/Makefile b/security/putty/Makefile
index 692d324cbe72..737579584d25 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= putty
-PORTVERSION= 0.54
-PORTREVISION= 1
+PORTVERSION= 0.55
CATEGORIES= security ipv6
MASTER_SITES= http://the.earth.li/~sgtatham/putty/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
@@ -25,7 +24,7 @@ CFLAGS+= -DIPV6
.endif
PLIST_FILES= bin/plink bin/pscp bin/psftp
-MAN1= plink.1
+MAN1= plink.1 pscp.1 psftp.1
.ifndef WITHOUT_GTK
USE_GNOME= gtk12
diff --git a/security/putty/distinfo b/security/putty/distinfo
index 0e515a7a23a4..fa95cae85989 100644
--- a/security/putty/distinfo
+++ b/security/putty/distinfo
@@ -1,2 +1,2 @@
-MD5 (putty-0.54.tar.gz) = ea6de3bc40bb34f4a4a8c861c08e6f31
-SIZE (putty-0.54.tar.gz) = 901120
+MD5 (putty-0.55.tar.gz) = b827836bec1109a2c0af9af0f9ae0bae
+SIZE (putty-0.55.tar.gz) = 1280000
diff --git a/security/putty/files/patch-Makefile.gtk b/security/putty/files/patch-Makefile.gtk
index dc11f9527b88..1aff4c1f2c40 100644
--- a/security/putty/files/patch-Makefile.gtk
+++ b/security/putty/files/patch-Makefile.gtk
@@ -1,15 +1,15 @@
---- Makefile.gtk.orig Thu Feb 12 19:43:43 2004
-+++ Makefile.gtk Fri Feb 13 14:48:57 2004
+--- Makefile.gtk.orig Tue Aug 3 19:42:46 2004
++++ Makefile.gtk Wed Aug 4 09:58:44 2004
@@ -80,7 +80,7 @@
# TOOLPATH = /opt/gcc/bin
CC = $(TOOLPATH)cc
--CFLAGS = -O2 -Wall -Werror -g -I. -I.. -I../charset `gtk-config --cflags`
-+CFLAGS += -Wall -g -I. -I.. -I../charset `gtk-config --cflags`
+-CFLAGS = -O2 -Wall -Werror -g -I.././ -I../charset/ -I../unix/ -I../mac/ \
++CFLAGS += -O2 -Wall -g -I.././ -I../charset/ -I../unix/ -I../mac/ \
+ `gtk-config --cflags`
XLDFLAGS = `gtk-config --libs`
ULDFLAGS =#
- INSTALL=install
-@@ -97,7 +97,11 @@
+@@ -98,7 +98,11 @@
%.o:
$(CC) $(COMPAT) $(FWHACK) $(XFLAGS) $(CFLAGS) -c $<
@@ -21,32 +21,33 @@
plink: be_all.o cmdline.o ldisc.o logging.o misc.o portfwd.o proxy.o raw.o \
rlogin.o settings.o signal.o ssh.o sshaes.o sshblowf.o \
-@@ -560,7 +564,7 @@
+@@ -616,7 +620,7 @@
+
version.o: FORCE;
- # Hack to force version.o to be rebuilt always
FORCE:
- if test -z "$(VER)" && (cd ..; md5sum -c manifest); then \
+ if test -z "$(VER)" ; then \
$(CC) $(COMPAT) $(FWHACK) $(XFLAGS) $(CFLAGS) `cat ../version.def` -c ../version.c; \
else \
$(CC) $(COMPAT) $(FWHACK) $(XFLAGS) $(CFLAGS) $(VER) -c ../version.c; \
-@@ -572,17 +576,17 @@
+@@ -625,17 +629,21 @@
$(INSTALL_PROGRAM) -m 755 plink $(DESTDIR)$(bindir)/plink
$(INSTALL_PROGRAM) -m 755 pscp $(DESTDIR)$(bindir)/pscp
$(INSTALL_PROGRAM) -m 755 psftp $(DESTDIR)$(bindir)/psftp
-+ $(INSTALL_DATA) -m 644 plink.1 $(DESTDIR)$(man1dir)/plink.1
+ifdef PUTTY_WITH_GTK
$(INSTALL_PROGRAM) -m 755 pterm $(DESTDIR)$(bindir)/pterm
$(INSTALL_PROGRAM) -m 755 putty $(DESTDIR)$(bindir)/putty
$(INSTALL_PROGRAM) -m 755 puttygen $(DESTDIR)$(bindir)/puttygen
$(INSTALL_PROGRAM) -m 755 puttytel $(DESTDIR)$(bindir)/puttytel
-- $(INSTALL_DATA) -m 644 plink.1 $(DESTDIR)$(man1dir)/plink.1
-- $(INSTALL_DATA) -m 644 pscp.1 $(DESTDIR)$(man1dir)/pscp.1
-- $(INSTALL_DATA) -m 644 psftp.1 $(DESTDIR)$(man1dir)/psftp.1
- $(INSTALL_DATA) -m 644 pterm.1 $(DESTDIR)$(man1dir)/pterm.1
- $(INSTALL_DATA) -m 644 putty.1 $(DESTDIR)$(man1dir)/putty.1
- $(INSTALL_DATA) -m 644 puttygen.1 $(DESTDIR)$(man1dir)/puttygen.1
- $(INSTALL_DATA) -m 644 puttytel.1 $(DESTDIR)$(man1dir)/puttytel.1
++endif
+ $(INSTALL_DATA) -m 644 ../doc/plink.1 $(DESTDIR)$(man1dir)/plink.1
+ $(INSTALL_DATA) -m 644 ../doc/pscp.1 $(DESTDIR)$(man1dir)/pscp.1
+ $(INSTALL_DATA) -m 644 ../doc/psftp.1 $(DESTDIR)$(man1dir)/psftp.1
++ifdef PUTTY_WITH_GTK
+ $(INSTALL_DATA) -m 644 ../doc/pterm.1 $(DESTDIR)$(man1dir)/pterm.1
+ $(INSTALL_DATA) -m 644 ../doc/putty.1 $(DESTDIR)$(man1dir)/putty.1
+ $(INSTALL_DATA) -m 644 ../doc/puttygen.1 $(DESTDIR)$(man1dir)/puttygen.1
+ $(INSTALL_DATA) -m 644 ../doc/puttytel.1 $(DESTDIR)$(man1dir)/puttytel.1
+endif
install-strip: