aboutsummaryrefslogtreecommitdiff
path: root/security/pwman/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-08-09 15:03:49 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-08-09 15:03:49 +0000
commitc9c0fba3555ebe2bc14b5a4b9a85b7922a1c5083 (patch)
tree4506c7cfc28676878e446067f401bdad4b7eee58 /security/pwman/Makefile
parent60c7153b80b5a1a6f4449f0b95fe77af086781d8 (diff)
Notes
Diffstat (limited to 'security/pwman/Makefile')
-rw-r--r--security/pwman/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/security/pwman/Makefile b/security/pwman/Makefile
index 55e7a8136a73..9449ecdc544c 100644
--- a/security/pwman/Makefile
+++ b/security/pwman/Makefile
@@ -2,31 +2,33 @@
# $FreeBSD$
PORTNAME= pwman
-PORTVERSION= 0.4.0
-PORTREVISION= 1
+PORTVERSION= 0.4.4
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Console password management application based on gpg(me)
-LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2
+LICENSE= GPLv2 # (or later)
+
RUN_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
+USE_GNOME= libxml2
GNU_CONFIGURE= yes
-CFLAGS+= -Wno-return-type
-
+PORTDOCS= AUTHORS ChangeLog README TODO
PLIST_FILES= bin/convert_pwdb bin/pwdb2csv bin/pwman man/man1/pwman.1.gz
-PORTDOCS= AUTHORS COPYING ChangeLog README TODO
+
+CFLAGS+= -Wno-error=return-type
OPTIONS_DEFINE= DOCS
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/gpg|${LOCALBASE}/bin/gpg|g' ${WRKSRC}/src/options.c
+ @${REINPLACE_CMD} -e \
+ 's|/usr/bin|${LOCALBASE}/bin|' ${WRKSRC}/src/options.c
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>