aboutsummaryrefslogtreecommitdiff
path: root/security/py-PF/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-02-09 21:25:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-02-09 21:25:26 +0000
commitfeb4910a3724aa099417b662dec67b69c0c3b126 (patch)
treecb841c720b71cc73c2bc5869fee3d3486d9a11bc /security/py-PF/Makefile
parentcfa79e038052586d609d95925b587badd6a72f1d (diff)
Notes
Diffstat (limited to 'security/py-PF/Makefile')
-rw-r--r--security/py-PF/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/security/py-PF/Makefile b/security/py-PF/Makefile
new file mode 100644
index 000000000000..7a308a42ea6a
--- /dev/null
+++ b/security/py-PF/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: py-PF
+# Date created: 2009-02-07
+# Whom: Sofian Brabez <sbrabez@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PF
+PORTVERSION= 0.0.2
+CATEGORIES= security python
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= ${PYTHON_PKGNAMEPREFIX:C/[0-9]+//}${PORTNAME:L}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PYTHON_PKGNAMEPREFIX:C/[0-9]+//}${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= sbrabez@gmail.com
+COMMENT= A pure-Python module for managing OpenBSD Packet Filter
+
+USE_PYTHON= 2.5+
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= ${PYTHON_PKGNAMEPREFIX:C/[0-9]+//}_${PORTNAME}
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+SUB_FILES= pkg-message
+
+post-install:
+.if !defined(BATCH)
+ @${CAT} ${PKGMESSAGE}
+.endif
+
+.include <bsd.port.mk>