aboutsummaryrefslogtreecommitdiff
path: root/security/py-RestrictedPython/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-10-10 02:46:28 +0000
committerWen Heping <wen@FreeBSD.org>2011-10-10 02:46:28 +0000
commitb6f3573e37d8d779f6aaf5496bced4e2dbda21a7 (patch)
treeb4c04698c00cc72104a2fb30c410d7710ce99806 /security/py-RestrictedPython/Makefile
parent03a5ea3e02b765df1f1f6e381a6bbe5e97b16abb (diff)
RestrictedPython provides a restricted execution environment for Python,
e.g. for running untrusted code. WWW: http://pypi.python.org/pypi/ExtensionClass Submitted by: Ruslan Mahmatkhanov <cvs-src@yandex.ru> (via GitHub)
Notes
Notes: svn path=/head/; revision=283283
Diffstat (limited to 'security/py-RestrictedPython/Makefile')
-rw-r--r--security/py-RestrictedPython/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/security/py-RestrictedPython/Makefile b/security/py-RestrictedPython/Makefile
new file mode 100644
index 000000000000..e189d393e0f6
--- /dev/null
+++ b/security/py-RestrictedPython/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-RestrictedPython
+# Date created: 10 October, 2011
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= RestrictedPython
+PORTVERSION= 3.6.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DIST_SUBDIR= zope
+
+MAINTAINER= cvs-src@yandex.ru
+COMMENT= Restricted execution environment for Python
+
+LICENSE= ZPL21
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+USE_ZIP= yes
+
+.include <bsd.port.mk>