aboutsummaryrefslogtreecommitdiff
path: root/security/py-acme
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-02-26 12:41:45 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-02-26 12:41:45 +0000
commit755f7c8540eddfe4d4df848e8af5bf77b8edf01a (patch)
tree0dbf7261daa9c79867f9511e82fd8e197898cd1b /security/py-acme
parentfd8428d31f8c4d2b8093a61af477aeec7a494a4d (diff)
downloadports-755f7c8540eddfe4d4df848e8af5bf77b8edf01a.tar.gz
ports-755f7c8540eddfe4d4df848e8af5bf77b8edf01a.zip
Notes
Diffstat (limited to 'security/py-acme')
-rw-r--r--security/py-acme/Makefile20
-rw-r--r--security/py-acme/distinfo4
2 files changed, 14 insertions, 10 deletions
diff --git a/security/py-acme/Makefile b/security/py-acme/Makefile
index ebf9b381fe3a..b7254015dca0 100644
--- a/security/py-acme/Makefile
+++ b/security/py-acme/Makefile
@@ -2,27 +2,31 @@
# $FreeBSD$
PORTNAME= acme
-PORTVERSION= 0.3.0
+PORTVERSION= 0.4.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= cpm@fbsd.es
-COMMENT= ACME implementation
+COMMENT= ACME protocol implementation in Python
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>0:${PORTSDIR}/devel/py-pyasn1 \
- ${PYTHON_PKGNAMEPREFIX}cryptography>=0.8:${PORTSDIR}/security/py-cryptography \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0.8:${PORTSDIR}/security/py-cryptography \
${PYTHON_PKGNAMEPREFIX}ndg_httpsclient>0:${PORTSDIR}/net/py-ndg_httpsclient \
- ${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:${PORTSDIR}/devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}pyasn1>0:${PORTSDIR}/devel/py-pyasn1 \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0.13:${PORTSDIR}/security/py-openssl \
${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:${PORTSDIR}/devel/py-pyrfc3339 \
${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
${PYTHON_PKGNAMEPREFIX}requests>0:${PORTSDIR}/www/py-requests \
- ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:${PORTSDIR}/devel/py-six \
- ${PYTHON_PKGNAMEPREFIX}werkzeug>0:${PORTSDIR}/www/py-werkzeug
+ ${PYTHON_PKGNAMEPREFIX}setuptools${PYTHON_SUFFIX}>0:${PORTSDIR}/devel/py-setuptools${PYTHON_SUFFIX} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}werkzeug>0:${PORTSDIR}/www/py-werkzeug \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:${PORTSDIR}/devel/py-nose
-USES= gmake python
+USES= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/security/py-acme/distinfo b/security/py-acme/distinfo
index f8b8a62b6e88..bf2645868126 100644
--- a/security/py-acme/distinfo
+++ b/security/py-acme/distinfo
@@ -1,2 +1,2 @@
-SHA256 (acme-0.3.0.tar.gz) = 7cd1568a28fa5717c6e68eeede835bb6b60a438abdbe1cce2c04dfc4d968cef4
-SIZE (acme-0.3.0.tar.gz) = 87416
+SHA256 (acme-0.4.0.tar.gz) = 4f7eca323d139ecbaf1c8cc20a6a30c367e97e93814e3edc778340aae717729c
+SIZE (acme-0.4.0.tar.gz) = 87407