aboutsummaryrefslogtreecommitdiff
path: root/security/py-artifacts
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-06-05 19:26:26 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-06-05 19:26:26 +0000
commit640d06a79694d1c09fbbfafe16c5b091bd1ec410 (patch)
tree2cba23c19d958f7dd347265dbb8526450d1b0d6f /security/py-artifacts
parent89bcc7231644fa741061d1e2685bce4bd4f6a660 (diff)
downloadports-640d06a79694d1c09fbbfafe16c5b091bd1ec410.tar.gz
ports-640d06a79694d1c09fbbfafe16c5b091bd1ec410.zip
Notes
Diffstat (limited to 'security/py-artifacts')
-rw-r--r--security/py-artifacts/Makefile5
-rw-r--r--security/py-artifacts/distinfo6
-rw-r--r--security/py-artifacts/files/patch-setup.py11
3 files changed, 18 insertions, 4 deletions
diff --git a/security/py-artifacts/Makefile b/security/py-artifacts/Makefile
index 6b83462f85b2..60adddf54b8e 100644
--- a/security/py-artifacts/Makefile
+++ b/security/py-artifacts/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= artifacts
-PORTVERSION= 20170513
+PORTVERSION= 20170522
CATEGORIES= security python
MASTER_SITES= CHEESESHOP \
https://github.com/ForensicArtifacts/artifacts/releases/download/${PORTVERSION}/
@@ -15,9 +15,12 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yapf>=0:textproc/py-yapf
NO_ARCH= yes
USES= python
USE_PYTHON= distutils autoplist
+DO_MAKE_TEST= ${SETENV} ${TEST_ENV} ${PYTHON_CMD}
+TEST_TARGET= run_tests.py
.include <bsd.port.mk>
diff --git a/security/py-artifacts/distinfo b/security/py-artifacts/distinfo
index 8332940e0cef..dd12119579a6 100644
--- a/security/py-artifacts/distinfo
+++ b/security/py-artifacts/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1494789316
-SHA256 (artifacts-20170513.tar.gz) = 65be32bf91d1f36804c85b532f029b8cc56c5cd29ee03a411613c68b3936a9f1
-SIZE (artifacts-20170513.tar.gz) = 49564
+TIMESTAMP = 1496500460
+SHA256 (artifacts-20170522.tar.gz) = a421282bbe1911bec482144052a9cfb0307d1c3a4f1a936e2dc111b31988d126
+SIZE (artifacts-20170522.tar.gz) = 58267
diff --git a/security/py-artifacts/files/patch-setup.py b/security/py-artifacts/files/patch-setup.py
new file mode 100644
index 000000000000..611e33dcbb82
--- /dev/null
+++ b/security/py-artifacts/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2017-05-22 18:44:24 UTC
++++ setup.py
+@@ -123,7 +123,7 @@ setup(
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ ],
+- packages=find_packages('.', exclude=[u'tests', u'tests.*', u'tools']),
++ packages=find_packages('.', exclude=[u'tests', u'tests.*', u'tools', u'utils']),
+ package_dir={'artifacts': 'artifacts'},
+ data_files=[
+ ('share/artifacts', glob.glob(os.path.join('data', '*'))),