aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot-dns-cloudflare
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:30:18 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:30:18 +0000
commit80288e8d2d6c87d166aff8cb1801d637f8546380 (patch)
tree85ecd14b0f9e1bab042d6e64e97e8caac92e6c74 /security/py-certbot-dns-cloudflare
parent2a4e97cbb847273bf0ab7b5ca554ef5b82afdec3 (diff)
downloadports-80288e8d2d6c87d166aff8cb1801d637f8546380.tar.gz
ports-80288e8d2d6c87d166aff8cb1801d637f8546380.zip
Notes
Diffstat (limited to 'security/py-certbot-dns-cloudflare')
-rw-r--r--security/py-certbot-dns-cloudflare/Makefile31
-rw-r--r--security/py-certbot-dns-cloudflare/distinfo3
-rw-r--r--security/py-certbot-dns-cloudflare/pkg-descr3
3 files changed, 37 insertions, 0 deletions
diff --git a/security/py-certbot-dns-cloudflare/Makefile b/security/py-certbot-dns-cloudflare/Makefile
new file mode 100644
index 000000000000..abe4c3a2b7d4
--- /dev/null
+++ b/security/py-certbot-dns-cloudflare/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= certbot-dns-cloudflare
+PORTVERSION= ${ACME_VERSION}
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Cloudflare DNS plugin for Certbot
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION}:security/py-acme@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION}:security/py-certbot@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cloudflare>=1.5.1:dns/py-cloudflare@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${FLAVOR}
+
+.include "${.CURDIR}/../py-acme/version.mk"
+.include <bsd.port.mk>
diff --git a/security/py-certbot-dns-cloudflare/distinfo b/security/py-certbot-dns-cloudflare/distinfo
new file mode 100644
index 000000000000..171cdd8be2ef
--- /dev/null
+++ b/security/py-certbot-dns-cloudflare/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518080463
+SHA256 (certbot-dns-cloudflare-0.21.1.tar.gz) = b284188339f24019312480829a7357ba2b932ded39aa7ff768e26d038a45a782
+SIZE (certbot-dns-cloudflare-0.21.1.tar.gz) = 12938
diff --git a/security/py-certbot-dns-cloudflare/pkg-descr b/security/py-certbot-dns-cloudflare/pkg-descr
new file mode 100644
index 000000000000..c0148d3f4c80
--- /dev/null
+++ b/security/py-certbot-dns-cloudflare/pkg-descr
@@ -0,0 +1,3 @@
+This is the Cloudflare DNS Authenticator plugin for Certbot (security/py-certbot).
+
+WWW: https://github.com/certbot/certbot