aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2017-04-30 14:26:41 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2017-04-30 14:26:41 +0000
commitbd251adcb6a393657c39b0696f200ee64bacb408 (patch)
tree19a2d3bf91b85fddf246a4326292ef8d9db52987 /security/py-certbot
parent85be9c0c6703d0666f750a8203b92f7d71f8ea15 (diff)
Notes
Diffstat (limited to 'security/py-certbot')
-rw-r--r--security/py-certbot/Makefile1
-rw-r--r--security/py-certbot/files/patch-setup.py21
2 files changed, 22 insertions, 0 deletions
diff --git a/security/py-certbot/Makefile b/security/py-certbot/Makefile
index 34b94ec1221d..f9b4c2ed04c5 100644
--- a/security/py-certbot/Makefile
+++ b/security/py-certbot/Makefile
@@ -3,6 +3,7 @@
PORTNAME= certbot
PORTVERSION= 0.13.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
diff --git a/security/py-certbot/files/patch-setup.py b/security/py-certbot/files/patch-setup.py
new file mode 100644
index 000000000000..3f0c35db5b0b
--- /dev/null
+++ b/security/py-certbot/files/patch-setup.py
@@ -0,0 +1,21 @@
+--- setup.py.orig 2017-04-30 10:33:38 UTC
++++ setup.py
+@@ -36,7 +36,6 @@ version = meta['version']
+ # https://github.com/pypa/pip/issues/988 for more info.
+ install_requires = [
+ 'acme=={0}'.format(version),
+- 'argparse',
+ # We technically need ConfigArgParse 0.10.0 for Python 2.6 support, but
+ # saying so here causes a runtime error against our temporary fork of 0.9.3
+ # in which we added 2.6 support (see #2243), so we relax the requirement.
+@@ -56,6 +55,10 @@ install_requires = [
+ 'zope.interface',
+ ]
+
++# env markers cause problems with older pip and setuptools
++if sys.version_info < (2, 7):
++ install_requires.append('argparse')
++
+ dev_extras = [
+ # Pin astroid==1.3.5, pylint==1.4.2 as a workaround for #289
+ 'astroid==1.3.5',