aboutsummaryrefslogtreecommitdiff
path: root/security/py-clamav
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-01-08 17:28:39 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-01-08 17:28:39 +0000
commita2f95abf799356b964aa7b94ca1db8dfb2f8888b (patch)
tree77a0d339b8b9d5c3290e4e212fae2c09b2b9517f /security/py-clamav
parent1b819830f1346a13350f6435ec1e2c15e8de9845 (diff)
downloadports-a2f95abf799356b964aa7b94ca1db8dfb2f8888b.tar.gz
ports-a2f95abf799356b964aa7b94ca1db8dfb2f8888b.zip
Notes
Diffstat (limited to 'security/py-clamav')
-rw-r--r--security/py-clamav/Makefile44
-rw-r--r--security/py-clamav/distinfo2
-rw-r--r--security/py-clamav/pkg-descr10
-rw-r--r--security/py-clamav/pkg-plist3
4 files changed, 59 insertions, 0 deletions
diff --git a/security/py-clamav/Makefile b/security/py-clamav/Makefile
new file mode 100644
index 000000000000..b45be67022e1
--- /dev/null
+++ b/security/py-clamav/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: py-clamav
+# Date created: 26 Dec 2004
+# Whom: Marcus Grando <marcus@corp.grupos.com.br>
+#
+# $FreeBSD$
+#
+
+PORTNAME= clamav
+PORTVERSION= 0.2.1
+CATEGORIES= security python
+MASTER_SITES= http://norman.free.fr/norman/python/pyclamav/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= py${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= marcus@corp.grupos.com.br
+COMMENT= A python binding to libclamav written in C
+
+LIB_DEPENDS= clamav.1:${PORTSDIR}/security/clamav
+
+DIST_SUBDIR= python
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PYDISTUTILS_BUILDARGS= build_ext -I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+DOCSDIR?= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR?= ${PREFIX}/share/examples/py-${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= *
+PLIST_SUB+= EXAMPLES=""
+.else
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.py ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/security/py-clamav/distinfo b/security/py-clamav/distinfo
new file mode 100644
index 000000000000..523c2f808fbf
--- /dev/null
+++ b/security/py-clamav/distinfo
@@ -0,0 +1,2 @@
+MD5 (python/pyclamav-0.2.1.tar.gz) = d802d2e9076bd1e17023dc8276083fd3
+SIZE (python/pyclamav-0.2.1.tar.gz) = 10813
diff --git a/security/py-clamav/pkg-descr b/security/py-clamav/pkg-descr
new file mode 100644
index 000000000000..3b1f3beb80c8
--- /dev/null
+++ b/security/py-clamav/pkg-descr
@@ -0,0 +1,10 @@
+pyClamAV is a python binding to libclamav written
+in C.
+
+By using pyClamAV, you can add virus detection
+capabilities to your python software in an efficient
+and easy way.
+
+WWW: http://norman.free.fr/norman/python/pyclamav/
+
+Marcus Grando <marcus@corp.grupos.com.br>
diff --git a/security/py-clamav/pkg-plist b/security/py-clamav/pkg-plist
new file mode 100644
index 000000000000..65fb69a17e42
--- /dev/null
+++ b/security/py-clamav/pkg-plist
@@ -0,0 +1,3 @@
+lib/%%PYTHON_VERSION%%/site-packages/pyclamav.so
+%%EXAMPLES%%%%EXAMPLESDIR%%/example.py
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%