aboutsummaryrefslogtreecommitdiff
path: root/security/py-cryptography
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-07-01 04:55:57 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-07-01 04:55:57 +0000
commitae42ee59b2a709bd4ac5609c28a1db4d7a843b1e (patch)
tree2bd9f5fe9b97e727db719d1bdb710b9546987842 /security/py-cryptography
parent98b697b9c5dc16b8d915c6db25687f0a6e7d4d9f (diff)
downloadports-ae42ee59b2a709bd4ac5609c28a1db4d7a843b1e.tar.gz
ports-ae42ee59b2a709bd4ac5609c28a1db4d7a843b1e.zip
Notes
Diffstat (limited to 'security/py-cryptography')
-rw-r--r--security/py-cryptography/Makefile3
-rw-r--r--security/py-cryptography/distinfo4
-rw-r--r--security/py-cryptography/files/patch-setup.py56
3 files changed, 3 insertions, 60 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 8d898901cd0b..fd413fd80c9d 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cryptography
-PORTVERSION= 0.2.2
-PORTREVISION= 1
+PORTVERSION= 0.4
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-cryptography/distinfo b/security/py-cryptography/distinfo
index 072c81fe2d52..0354cbfc7486 100644
--- a/security/py-cryptography/distinfo
+++ b/security/py-cryptography/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cryptography-0.2.2.tar.gz) = 01cbf64277f1a08c70ba6206b3b5c24ae49f346937299074ad89956652d69aeb
-SIZE (cryptography-0.2.2.tar.gz) = 13772494
+SHA256 (cryptography-0.4.tar.gz) = 5ef81de44c87a87779710cbb476ffbec86a4a6c0bd2a5bebeccc3bfb3c3478e5
+SIZE (cryptography-0.4.tar.gz) = 260891
diff --git a/security/py-cryptography/files/patch-setup.py b/security/py-cryptography/files/patch-setup.py
deleted file mode 100644
index 4eed97f229b9..000000000000
--- a/security/py-cryptography/files/patch-setup.py
+++ /dev/null
@@ -1,56 +0,0 @@
---- ./setup.py.orig 2014-02-23 08:35:18.000000000 +1100
-+++ ./setup.py 2014-02-24 19:34:58.741325597 +1100
-@@ -14,7 +14,8 @@
- from distutils.command.build import build
-
- from setuptools import setup, find_packages
--
-+from setuptools.command.test import test as TestCommand
-+import sys
-
- base_dir = os.path.dirname(__file__)
-
-@@ -31,6 +32,12 @@
- SIX_DEPENDENCY
- ]
-
-+test_requirements = [
-+ "pytest",
-+ "pretend",
-+ "iso8601"
-+]
-+
-
- class cffi_build(build):
- """
-@@ -63,6 +70,16 @@
-
- build.finalize_options(self)
-
-+class PyTest(TestCommand):
-+ def finalize_options(self):
-+ TestCommand.finalize_options(self)
-+ self.test_args = []
-+ self.test_suite = True
-+ def run_tests(self):
-+ #import here, cause outside the eggs aren't loaded
-+ import pytest
-+ errno = pytest.main(self.test_args)
-+ sys.exit(errno)
-
- with open(os.path.join(base_dir, "README.rst")) as f:
- long_description = f.read()
-@@ -105,11 +122,12 @@
-
- install_requires=requirements,
- setup_requires=requirements,
--
-+ tests_require=test_requirements,
- # for cffi
- zip_safe=False,
- ext_package="cryptography",
- cmdclass={
- "build": cffi_build,
-+ "test": PyTest,
- }
- )