aboutsummaryrefslogtreecommitdiff
path: root/security/py-cryptography
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-04-24 13:36:29 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-04-24 13:36:29 +0000
commit14dc81245181287ac763c49773f8a8b4fbcd1e15 (patch)
tree531a599a1f7430f900bb0c5e5c0d30a0ca00a0aa /security/py-cryptography
parentff472fed3cc3b920a91ec13a28681edc943cab88 (diff)
downloadports-14dc81245181287ac763c49773f8a8b4fbcd1e15.tar.gz
ports-14dc81245181287ac763c49773f8a8b4fbcd1e15.zip
Notes
Diffstat (limited to 'security/py-cryptography')
-rw-r--r--security/py-cryptography/Makefile5
-rw-r--r--security/py-cryptography/distinfo4
-rw-r--r--security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_engine.py10
-rw-r--r--security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_rand.py12
-rw-r--r--security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_ssl.py41
-rw-r--r--security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_x509__vfy.py20
6 files changed, 18 insertions, 74 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 941c4bd55043..2125d1d2463a 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -2,13 +2,13 @@
# $FreeBSD$
PORTNAME= cryptography
-PORTVERSION= 0.7.2
+PORTVERSION= 0.8.2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
-COMMENT= Expose cryptographic recipes and primitives to Python developers
+COMMENT= Cryptographic recipes and primitives for Python developers
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -16,7 +16,6 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=0.8:${PORTSDIR}/devel/py-cffi \
${PYTHON_PKGNAMEPREFIX}six>=1.4.1:${PORTSDIR}/devel/py-six \
${PYTHON_PKGNAMEPREFIX}asn1>0:${PORTSDIR}/devel/py-asn1
-
RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest \
${PYTHON_PKGNAMEPREFIX}iso8601>0:${PORTSDIR}/devel/py-iso8601
diff --git a/security/py-cryptography/distinfo b/security/py-cryptography/distinfo
index 89a2851d228e..a65f20312e5f 100644
--- a/security/py-cryptography/distinfo
+++ b/security/py-cryptography/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cryptography-0.7.2.tar.gz) = fab7fcdde360ec6614442d0321dcd0eff5e43544cb30d975e9d75a914a4cdf78
-SIZE (cryptography-0.7.2.tar.gz) = 247477
+SHA256 (cryptography-0.8.2.tar.gz) = 1c9a022ab3decaf152093e2ef2d5ee4258c72c7d429446c86bd68ff8c0929db6
+SIZE (cryptography-0.8.2.tar.gz) = 268288
diff --git a/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_engine.py b/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_engine.py
deleted file mode 100644
index 9f05a871fad1..000000000000
--- a/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_engine.py
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/cryptography/hazmat/bindings/openssl/engine.py.orig 2015-01-16 13:26:59 UTC
-+++ src/cryptography/hazmat/bindings/openssl/engine.py
-@@ -49,7 +49,6 @@ int ENGINE_init(ENGINE *);
- int ENGINE_finish(ENGINE *);
- void ENGINE_load_openssl(void);
- void ENGINE_load_dynamic(void);
--void ENGINE_load_cryptodev(void);
- void ENGINE_load_builtin_engines(void);
- void ENGINE_cleanup(void);
- ENGINE *ENGINE_get_default_RSA(void);
diff --git a/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_rand.py b/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_rand.py
deleted file mode 100644
index 6534af9bb538..000000000000
--- a/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_rand.py
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/cryptography/hazmat/bindings/openssl/rand.py.orig 2015-01-16 13:26:59 UTC
-+++ src/cryptography/hazmat/bindings/openssl/rand.py
-@@ -16,9 +16,6 @@ void ERR_load_RAND_strings(void);
- void RAND_seed(const void *, int);
- void RAND_add(const void *, int, double);
- int RAND_status(void);
--int RAND_egd(const char *);
--int RAND_egd_bytes(const char *, int);
--int RAND_query_egd_bytes(const char *, unsigned char *, int);
- const char *RAND_file_name(char *, size_t);
- int RAND_load_file(const char *, long);
- int RAND_write_file(const char *);
diff --git a/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_ssl.py b/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_ssl.py
index e84838f20e14..feb2da8902ad 100644
--- a/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_ssl.py
+++ b/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_ssl.py
@@ -1,30 +1,17 @@
---- src/cryptography/hazmat/bindings/openssl/ssl.py.orig 2015-01-16 13:26:59 UTC
+From 622409947f6e64fcabbf2b4da2ed086abc06ed85 Mon Sep 17 00:00:00 2001
+From: Bernard Spil <Sp1l@users.noreply.github.com>
+Date: Wed, 15 Apr 2015 11:09:32 +0200
+Subject: [PATCH] LibreSSL added ALPN support in 2.1.3
+Link: https://github.com/pyca/cryptography/pull/1849
+
+--- src/cryptography/hazmat/bindings/openssl/ssl.py.orig 2015-04-24 12:57:06 UTC
+++ src/cryptography/hazmat/bindings/openssl/ssl.py
-@@ -189,10 +189,6 @@ int SSL_shutdown(SSL *);
- const char *SSL_get_cipher_list(const SSL *, int);
- Cryptography_STACK_OF_SSL_CIPHER *SSL_get_ciphers(const SSL *);
-
--const COMP_METHOD *SSL_get_current_compression(SSL *);
--const COMP_METHOD *SSL_get_current_expansion(SSL *);
--const char *SSL_COMP_get_name(const COMP_METHOD *);
--
- /* context */
- void SSL_CTX_free(SSL_CTX *);
- long SSL_CTX_set_timeout(SSL_CTX *, long);
-@@ -415,6 +411,16 @@ static const long Cryptography_HAS_RELEA
- const long SSL_MODE_RELEASE_BUFFERS = 0;
+@@ -526,7 +526,7 @@ static const long Cryptography_HAS_NEXTP
#endif
-+#ifndef OPENSSL_NO_COMP
-+const COMP_METHOD *SSL_get_current_compression(SSL *s);
-+const COMP_METHOD *SSL_get_current_expansion(SSL *s);
-+const char *SSL_COMP_get_name(const COMP_METHOD *comp);
-+#else
-+const void *SSL_get_current_compression(SSL *s);
-+const void *SSL_get_current_expansion(SSL *s);
-+const char *SSL_COMP_get_name(const void *comp);
-+#endif
-+
- #ifdef SSL_OP_NO_COMPRESSION
- static const long Cryptography_HAS_OP_NO_COMPRESSION = 1;
- #else
+ /* ALPN was added in OpenSSL 1.0.2. */
+-#if OPENSSL_VERSION_NUMBER < 0x10002001L
++#if OPENSSL_VERSION_NUMBER < 0x10002001L && !defined(LIBRESSL_VERSION_NUMBER)
+ int (*SSL_CTX_set_alpn_protos)(SSL_CTX *,
+ const unsigned char *,
+ unsigned) = NULL;
diff --git a/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_x509__vfy.py b/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_x509__vfy.py
deleted file mode 100644
index 3159a2add63b..000000000000
--- a/security/py-cryptography/files/patch-src_cryptography_hazmat_bindings_openssl_x509__vfy.py
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/cryptography/hazmat/bindings/openssl/x509_vfy.py.orig 2015-01-16 13:26:59 UTC
-+++ src/cryptography/hazmat/bindings/openssl/x509_vfy.py
-@@ -191,7 +191,7 @@ int X509_VERIFY_PARAM_set1_ip_asc(X509_V
-
- CUSTOMIZATIONS = """
- /* OpenSSL 1.0.2+ verification error codes */
--#if OPENSSL_VERSION_NUMBER >= 0x10002000L
-+#if X509_V_ERR_EMAIL_MISMATCH
- static const long Cryptography_HAS_102_VERIFICATION_ERROR_CODES = 1;
- #else
- static const long Cryptography_HAS_102_VERIFICATION_ERROR_CODES = 0;
-@@ -207,7 +207,7 @@ static const long X509_V_ERR_IP_ADDRESS_
- #endif
-
- /* OpenSSL 1.0.2+ verification parameters */
--#if OPENSSL_VERSION_NUMBER >= 0x10002000L
-+#if X509_V_FLAG_PARTIAL_CHAIN
- static const long Cryptography_HAS_102_VERIFICATION_PARAMS = 1;
- #else
- static const long Cryptography_HAS_102_VERIFICATION_PARAMS = 0;