aboutsummaryrefslogtreecommitdiff
path: root/security/py-cybox/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-04-06 23:01:33 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-04-06 23:01:33 +0000
commit72f4d17a8b9a5e1039bf4fdc06faa89da24d016b (patch)
treee06f425983c263cd3624c40c1c5c78acc0b0fc12 /security/py-cybox/Makefile
parent334db61689ae56c781ac73214cd4c409546bfd51 (diff)
Distfile rerolled with a license file and some examples
Notes
Notes: svn path=/head/; revision=350421
Diffstat (limited to 'security/py-cybox/Makefile')
-rw-r--r--security/py-cybox/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/security/py-cybox/Makefile b/security/py-cybox/Makefile
index 465426f5ada9..70489d374ed9 100644
--- a/security/py-cybox/Makefile
+++ b/security/py-cybox/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cybox
PORTVERSION= 2.1.0.2
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,7 @@ MAINTAINER= antoine@FreeBSD.org
COMMENT= Python library for parsing, manipulating, and generating CybOX content
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:${PORTSDIR}/devel/py-dateutil \
${PYTHON_PKGNAMEPREFIX}lxml>=3.1:${PORTSDIR}/devel/py-lxml
@@ -20,11 +22,14 @@ USE_PYDISTUTILS=yes
PYDISTUTILS_AUTOPLIST=yes
PORTDOCS= README.rst
+PORTEXAMPLES= *
-OPTIONS_DEFINE= DOCS
+OPTIONS_DEFINE= DOCS EXAMPLES
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>