aboutsummaryrefslogtreecommitdiff
path: root/security/py-fail2ban
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2014-11-17 14:41:24 +0000
committerWen Heping <wen@FreeBSD.org>2014-11-17 14:41:24 +0000
commit0dbee8454bfe67f8b2e5d03f2c79f26c2e7968a9 (patch)
tree667b93033c7d337c2a4135289bb3ee0f2711afbc /security/py-fail2ban
parent122058b5a1cf8ca5267daec77f17915b368c080d (diff)
downloadports-0dbee8454bfe67f8b2e5d03f2c79f26c2e7968a9.tar.gz
ports-0dbee8454bfe67f8b2e5d03f2c79f26c2e7968a9.zip
Notes
Diffstat (limited to 'security/py-fail2ban')
-rw-r--r--security/py-fail2ban/Makefile5
-rw-r--r--security/py-fail2ban/distinfo4
-rw-r--r--security/py-fail2ban/files/patch-fail2banreader.py11
-rw-r--r--security/py-fail2ban/files/patch-paths-freebsd.conf20
-rw-r--r--security/py-fail2ban/files/patch-recidive.conf15
-rw-r--r--security/py-fail2ban/files/patch-setup.py51
-rw-r--r--security/py-fail2ban/pkg-plist42
7 files changed, 68 insertions, 80 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index efd00be772e5..a7c3afd35307 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= fail2ban
-PORTVERSION= 0.9.0
-PORTREVISION= 4
+PORTVERSION= 0.9.1
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -16,7 +15,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3
USE_GITHUB= yes
GH_ACCOUNT= ${PORTNAME}
GH_PROJECT= ${PORTNAME}
-GH_COMMIT= c7f4c48
+GH_COMMIT= 2ab2bd8
GH_TAGNAME= ${PORTVERSION}
USES= python:2
diff --git a/security/py-fail2ban/distinfo b/security/py-fail2ban/distinfo
index e04874eca874..4f9fd41eb29b 100644
--- a/security/py-fail2ban/distinfo
+++ b/security/py-fail2ban/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fail2ban-0.9.0.tar.gz) = 981d2461a75d818934e2dcacf618ad9460ac4a6c05956f845f4d51c4d88000e0
-SIZE (fail2ban-0.9.0.tar.gz) = 274108
+SHA256 (fail2ban-0.9.1.tar.gz) = 8ad1135d4669d5fb0890f364880a4125ff793a39084100b80b65e52ab19deb78
+SIZE (fail2ban-0.9.1.tar.gz) = 299033
diff --git a/security/py-fail2ban/files/patch-fail2banreader.py b/security/py-fail2ban/files/patch-fail2banreader.py
deleted file mode 100644
index 7c5760aabf85..000000000000
--- a/security/py-fail2ban/files/patch-fail2banreader.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- fail2ban/client/fail2banreader.py.orig 2014-04-03 15:33:44.000000000 +0200
-+++ fail2ban/client/fail2banreader.py 2014-04-03 15:34:00.000000000 +0200
-@@ -45,7 +45,7 @@
- return ConfigReader.getOptions(self, "Definition", opts)
-
- def getOptions(self):
-- opts = [["int", "loglevel", "INFO" ],
-+ opts = [["string", "loglevel", "INFO" ],
- ["string", "logtarget", "STDERR"],
- ["string", "dbfile", "/var/lib/fail2ban/fail2ban.sqlite3"],
- ["int", "dbpurgeage", 86400]]
diff --git a/security/py-fail2ban/files/patch-paths-freebsd.conf b/security/py-fail2ban/files/patch-paths-freebsd.conf
deleted file mode 100644
index 7f917035e213..000000000000
--- a/security/py-fail2ban/files/patch-paths-freebsd.conf
+++ /dev/null
@@ -1,20 +0,0 @@
---- config/paths-freebsd.conf.orig 2014-03-15 01:18:01.000000000 +0100
-+++ config/paths-freebsd.conf 2014-04-03 09:49:23.000000000 +0200
-@@ -2,7 +2,7 @@
-
- [INCLUDES]
-
--before = common-paths.conf
-+before = paths-common.conf
-
- after = paths-overrides.local
-
-@@ -24,6 +24,8 @@
-
- syslog_local0 = /var/log/messages
-
-+syslog_user =
-+
- # Linux things
- # we fake to avoid parse error in startups
-
diff --git a/security/py-fail2ban/files/patch-recidive.conf b/security/py-fail2ban/files/patch-recidive.conf
deleted file mode 100644
index 5e832fbf58ce..000000000000
--- a/security/py-fail2ban/files/patch-recidive.conf
+++ /dev/null
@@ -1,15 +0,0 @@
---- config/filter.d/recidive.conf.orig 2014-09-17 12:18:12.000000000 +0200
-+++ config/filter.d/recidive.conf 2014-09-17 12:19:16.000000000 +0200
-@@ -27,10 +27,10 @@
- # jail using this filter 'recidive', or change this line!
- _jailname = recidive
-
--failregex = ^(%(__prefix_line)s| %(_daemon)s%(__pid_re)s?:\s+)WARNING\s+\[(?!%(_jailname)s\])(?:.*)\]\s+Ban\s+<HOST>\s*$
-+failregex = ^(%(__prefix_line)s| %(_daemon)s%(__pid_re)s?:\s+)NOTICE\s+\[(?!%(_jailname)s\])(?:.*)\]\s+Ban\s+<HOST>\s*$
-
- [Init]
-
--journalmatch = _SYSTEMD_UNIT=fail2ban.service PRIORITY=4
-+journalmatch = _SYSTEMD_UNIT=fail2ban.service PRIORITY=5
-
- # Author: Tom Hendrikx, modifications by Amir Caspi
diff --git a/security/py-fail2ban/files/patch-setup.py b/security/py-fail2ban/files/patch-setup.py
index a8a782a966dd..ed9f33c083f5 100644
--- a/security/py-fail2ban/files/patch-setup.py
+++ b/security/py-fail2ban/files/patch-setup.py
@@ -1,13 +1,40 @@
---- setup.py.orig 2014-04-02 18:37:35.000000000 +0200
-+++ setup.py 2014-04-02 18:38:12.000000000 +0200
-@@ -141,10 +141,6 @@
- ),
- ('/var/lib/fail2ban',
- ''
-- ),
-- ('/usr/share/doc/fail2ban',
-- ['README.md', 'README.Solaris', 'DEVELOP', 'FILTERS',
-- 'doc/run-rootless.txt']
- )
- ],
+--- setup.py.orig 2014-11-08 10:14:31.000000000 +0100
++++ setup.py 2014-11-08 10:17:37.000000000 +0100
+@@ -96,26 +96,13 @@
+ 'bin/fail2ban-client',
+ 'bin/fail2ban-server',
+ 'bin/fail2ban-regex',
+- 'bin/fail2ban-testcases',
+ ],
+ packages = [
+ 'fail2ban',
+ 'fail2ban.client',
+ 'fail2ban.server',
+- 'fail2ban.tests',
+- 'fail2ban.tests.action_d',
+ ],
+ package_data = {
+- 'fail2ban.tests':
+- [ join(w[0], f).replace("fail2ban/tests/", "", 1)
+- for w in os.walk('fail2ban/tests/files')
+- for f in w[2]] +
+- [ join(w[0], f).replace("fail2ban/tests/", "", 1)
+- for w in os.walk('fail2ban/tests/config')
+- for f in w[2]] +
+- [ join(w[0], f).replace("fail2ban/tests/", "", 1)
+- for w in os.walk('fail2ban/tests/action_d')
+- for f in w[2]]
+ },
+ data_files = [
+ ('/etc/fail2ban',
+@@ -136,10 +123,6 @@
+ ),
+ ('/var/lib/fail2ban',
+ ''
+- ),
+- ('/usr/share/doc/fail2ban',
+- ['README.md', 'README.Solaris', 'DEVELOP', 'FILTERS',
+- 'doc/run-rootless.txt']
+ )
+ ],
**setup_extra
diff --git a/security/py-fail2ban/pkg-plist b/security/py-fail2ban/pkg-plist
index 5f59024ada30..7cea1acbdb7c 100644
--- a/security/py-fail2ban/pkg-plist
+++ b/security/py-fail2ban/pkg-plist
@@ -3,13 +3,17 @@ bin/fail2ban-regex
bin/fail2ban-server
%%ETCDIR%%/fail2ban.conf
%%ETCDIR%%/jail.conf
-%%ETCDIR%%/paths-freebsd.conf
%%ETCDIR%%/paths-common.conf
+%%ETCDIR%%/paths-debian.conf
+%%ETCDIR%%/paths-fedora.conf
+%%ETCDIR%%/paths-freebsd.conf
+%%ETCDIR%%/paths-osx.conf
%%ETCDIR%%/action.d/apf.conf
%%ETCDIR%%/action.d/badips.conf
%%ETCDIR%%/action.d/badips.py
%%ETCDIR%%/action.d/blocklist_de.conf
%%ETCDIR%%/action.d/bsd-ipfw.conf
+%%ETCDIR%%/action.d/cloudflare.conf
%%ETCDIR%%/action.d/complain.conf
%%ETCDIR%%/action.d/dshield.conf
%%ETCDIR%%/action.d/dummy.conf
@@ -19,7 +23,7 @@ bin/fail2ban-server
%%ETCDIR%%/action.d/ipfilter.conf
%%ETCDIR%%/action.d/ipfw.conf
%%ETCDIR%%/action.d/iptables-allports.conf
-%%ETCDIR%%/action.d/iptables-blocktype.conf
+%%ETCDIR%%/action.d/iptables-common.conf
%%ETCDIR%%/action.d/iptables-ipset-proto4.conf
%%ETCDIR%%/action.d/iptables-ipset-proto6-allports.conf
%%ETCDIR%%/action.d/iptables-ipset-proto6.conf
@@ -47,6 +51,7 @@ bin/fail2ban-server
%%ETCDIR%%/action.d/sendmail.conf
%%ETCDIR%%/action.d/shorewall.conf
%%ETCDIR%%/action.d/smtp.py
+%%ETCDIR%%/action.d/symbiosis-blacklist-allports.conf
%%ETCDIR%%/action.d/ufw.conf
%%ETCDIR%%/action.d/xarf-login-attack.conf
%%ETCDIR%%/filter.d/3proxy.conf
@@ -58,6 +63,7 @@ bin/fail2ban-server
%%ETCDIR%%/filter.d/apache-nohome.conf
%%ETCDIR%%/filter.d/apache-noscript.conf
%%ETCDIR%%/filter.d/apache-overflows.conf
+%%ETCDIR%%/filter.d/apache-shellshock.conf
%%ETCDIR%%/filter.d/assp.conf
%%ETCDIR%%/filter.d/asterisk.conf
%%ETCDIR%%/filter.d/bsd-sendmail.conf
@@ -68,8 +74,10 @@ bin/fail2ban-server
%%ETCDIR%%/filter.d/courier-auth.conf
%%ETCDIR%%/filter.d/courier-smtp.conf
%%ETCDIR%%/filter.d/cyrus-imap.conf
+%%ETCDIR%%/filter.d/directadmin.conf
%%ETCDIR%%/filter.d/dovecot.conf
%%ETCDIR%%/filter.d/dropbear.conf
+%%ETCDIR%%/filter.d/ejabberd-auth.conf
%%ETCDIR%%/filter.d/exim-common.conf
%%ETCDIR%%/filter.d/exim-spam.conf
%%ETCDIR%%/filter.d/exim.conf
@@ -80,15 +88,18 @@ bin/fail2ban-server
%%ETCDIR%%/filter.d/horde.conf
%%ETCDIR%%/filter.d/kerio.conf
%%ETCDIR%%/filter.d/lighttpd-auth.conf
+%%ETCDIR%%/filter.d/monit.conf
%%ETCDIR%%/filter.d/mysqld-auth.conf
%%ETCDIR%%/filter.d/nagios.conf
%%ETCDIR%%/filter.d/named-refused.conf
%%ETCDIR%%/filter.d/nginx-http-auth.conf
%%ETCDIR%%/filter.d/nsd.conf
%%ETCDIR%%/filter.d/openwebmail.conf
+%%ETCDIR%%/filter.d/oracleims.conf
%%ETCDIR%%/filter.d/pam-generic.conf
%%ETCDIR%%/filter.d/perdition.conf
%%ETCDIR%%/filter.d/php-url-fopen.conf
+%%ETCDIR%%/filter.d/portsentry.conf
%%ETCDIR%%/filter.d/postfix-sasl.conf
%%ETCDIR%%/filter.d/postfix.conf
%%ETCDIR%%/filter.d/proftpd.conf
@@ -195,23 +206,20 @@ bin/fail2ban-server
%%PYTHON_SITELIBDIR%%/fail2ban/server/ticket.pyc
%%PYTHON_SITELIBDIR%%/fail2ban/server/transmitter.py
%%PYTHON_SITELIBDIR%%/fail2ban/server/transmitter.pyc
-%%PYTHON_SITELIBDIR%%/fail2ban/tests/__init__.py
-%%PYTHON_SITELIBDIR%%/fail2ban/tests/__init__.pyc
-%%PYTHON_SITELIBDIR%%/fail2ban/tests/utils.py
-%%PYTHON_SITELIBDIR%%/fail2ban/tests/utils.pyc
man/man1/fail2ban-client.1.gz
man/man1/fail2ban-regex.1.gz
man/man1/fail2ban-server.1.gz
man/man1/fail2ban.1.gz
man/man5/fail2ban-jail.conf.5.gz
-@dirrm %%PYTHON_SITELIBDIR%%/fail2ban/tests
-@dirrm %%PYTHON_SITELIBDIR%%/fail2ban/server
-@dirrm %%PYTHON_SITELIBDIR%%/fail2ban/client
-@dirrm %%PYTHON_SITELIBDIR%%/fail2ban
-@dirrmtry %%ETCDIR%%/jail.d
-@dirrmtry %%ETCDIR%%/filter.d
-@dirrmtry %%ETCDIR%%/fail2ban.d
-@dirrmtry %%ETCDIR%%/action.d
-@dirrmtry %%ETCDIR%%
-@dirrmtry /var/run/fail2ban
-@dirrmtry /var/db/fail2ban
+@dir %%PYTHON_SITELIBDIR%%/fail2ban/server
+@dir %%PYTHON_SITELIBDIR%%/fail2ban/client
+@dir %%PYTHON_SITELIBDIR%%/fail2ban
+@dir %%ETCDIR%%/jail.d
+@dir %%ETCDIR%%/filter.d
+@dir %%ETCDIR%%/fail2ban.d
+@dir %%ETCDIR%%/action.d
+@dir %%ETCDIR%%
+@dir /var/run/fail2ban
+@dir /var/db/fail2ban
+@dir /var/lib/fail2ban
+@dir /var/lib