aboutsummaryrefslogtreecommitdiff
path: root/security/py-fchksum
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2014-04-15 15:02:31 +0000
committerSteve Wills <swills@FreeBSD.org>2014-04-15 15:02:31 +0000
commit4c17179eef64e778829f9e7fbcfdf9883c58b67f (patch)
tree0c6626eaf7a2af4d9cdbeb5bdee7d9ca433e4f38 /security/py-fchksum
parent69686c2a22aa14119b9c71f012d4af70987aa16d (diff)
downloadports-4c17179eef64e778829f9e7fbcfdf9883c58b67f.tar.gz
ports-4c17179eef64e778829f9e7fbcfdf9883c58b67f.zip
Notes
Diffstat (limited to 'security/py-fchksum')
-rw-r--r--security/py-fchksum/Makefile21
-rw-r--r--security/py-fchksum/distinfo2
-rw-r--r--security/py-fchksum/pkg-descr10
3 files changed, 33 insertions, 0 deletions
diff --git a/security/py-fchksum/Makefile b/security/py-fchksum/Makefile
new file mode 100644
index 000000000000..1617024cfa24
--- /dev/null
+++ b/security/py-fchksum/Makefile
@@ -0,0 +1,21 @@
+# Created by: ijliao
+# $FreeBSD$
+
+PORTNAME= fchksum
+PORTVERSION= 1.7.1
+CATEGORIES= security python
+MASTER_SITES= http://code.fluffytapeworm.com/projects/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= matthew@reztek.cz
+COMMENT= Python module to find the checksum of files
+
+LICENSE= GPLv2
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/fchksum.so
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= python-fchksum
+
+.include <bsd.port.mk>
diff --git a/security/py-fchksum/distinfo b/security/py-fchksum/distinfo
new file mode 100644
index 000000000000..8c3fe058b67b
--- /dev/null
+++ b/security/py-fchksum/distinfo
@@ -0,0 +1,2 @@
+SHA256 (python-fchksum-1.7.1.tar.gz) = 407625d2bf38be6fcbe8b01007d1803b5c5bd97249114c076edef4fd061405a7
+SIZE (python-fchksum-1.7.1.tar.gz) = 26724
diff --git a/security/py-fchksum/pkg-descr b/security/py-fchksum/pkg-descr
new file mode 100644
index 000000000000..aff9600176b1
--- /dev/null
+++ b/security/py-fchksum/pkg-descr
@@ -0,0 +1,10 @@
+fchksum is a Python module to find the checksum of files. Currently it
+supports crc32 and md5 checksums.
+
+The advantage of using fchksum over the python md5 and zlib(.crc32) modules
+is both ease of use and speed. You only need to tell it the filename and the
+actual work is done by C code. Compared to the implementing a read loop in
+python with the standard python modules, fchksum is approximatly 2.0x faster
+in md5 and 1.1x faster in crc32.
+
+WWW: http://users.dakotacom.net/~donut/programs/fchksum.html