aboutsummaryrefslogtreecommitdiff
path: root/security/py-fchksum
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-05 07:07:27 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-05 07:07:27 +0000
commit35f4343fa4d8406303456ca0d5405f7b1ca8962f (patch)
treedd39d1c10f6d5c13418c05d061562a8bac1c8707 /security/py-fchksum
parente5e4e1c40b3884683ad83f3c917b90e782c9ed26 (diff)
downloadports-35f4343fa4d8406303456ca0d5405f7b1ca8962f.tar.gz
ports-35f4343fa4d8406303456ca0d5405f7b1ca8962f.zip
Notes
Diffstat (limited to 'security/py-fchksum')
-rw-r--r--security/py-fchksum/Makefile21
-rw-r--r--security/py-fchksum/distinfo1
-rw-r--r--security/py-fchksum/pkg-comment1
-rw-r--r--security/py-fchksum/pkg-descr10
-rw-r--r--security/py-fchksum/pkg-plist1
5 files changed, 34 insertions, 0 deletions
diff --git a/security/py-fchksum/Makefile b/security/py-fchksum/Makefile
new file mode 100644
index 000000000000..bc83990ab6a8
--- /dev/null
+++ b/security/py-fchksum/Makefile
@@ -0,0 +1,21 @@
+# ex:ts=8
+# New ports collection makefile for: py-fckhsum
+# Date created: Jul 5, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= fchksum
+PORTVERSION= 1.3
+CATEGORIES= security python
+MASTER_SITES= http://www.azstarnet.com/~donut/programs/fchksum/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-fchksum/distinfo b/security/py-fchksum/distinfo
new file mode 100644
index 000000000000..d1c64b047c31
--- /dev/null
+++ b/security/py-fchksum/distinfo
@@ -0,0 +1 @@
+MD5 (python-fchksum-1.3.tar.gz) = f8d6c27f04d88a92ee3c5aa5ce07aed1
diff --git a/security/py-fchksum/pkg-comment b/security/py-fchksum/pkg-comment
new file mode 100644
index 000000000000..bbe489d91cc7
--- /dev/null
+++ b/security/py-fchksum/pkg-comment
@@ -0,0 +1 @@
+find the checksum of files
diff --git a/security/py-fchksum/pkg-descr b/security/py-fchksum/pkg-descr
new file mode 100644
index 000000000000..544057e88693
--- /dev/null
+++ b/security/py-fchksum/pkg-descr
@@ -0,0 +1,10 @@
+fchksum is a Python module to find the checksum of files. Currently it
+supports crc32 and md5 checksums.
+
+The advantage of using fchksum over the python md5 and zlib(.crc32) modules
+is both ease of use and speed. You only need to tell it the filename and the
+actual work is done by C code. Compared to the implementing a read loop in
+python with the standard python modules, fchksum is approximatly 2.0x faster
+in md5 and 1.1x faster in crc32.
+
+WWW: http://www.azstarnet.com/~donut/programs/fchksum.html
diff --git a/security/py-fchksum/pkg-plist b/security/py-fchksum/pkg-plist
new file mode 100644
index 000000000000..8d677e4add82
--- /dev/null
+++ b/security/py-fchksum/pkg-plist
@@ -0,0 +1 @@
+lib/%%PYTHON_VERSION%%/site-packages/fchksum.so