aboutsummaryrefslogtreecommitdiff
path: root/security/py-gixy
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2017-05-11 16:41:53 +0000
committerDan Langille <dvl@FreeBSD.org>2017-05-11 16:41:53 +0000
commit93bd0c4d1e0e18721728b5c14e414b6d955eee51 (patch)
treef6ada51a20997afa3cd9f372c73987ddfa5c69c3 /security/py-gixy
parentcbba37d4ebb1552d5b633266d2d9f5e5e40b755b (diff)
Notes
Diffstat (limited to 'security/py-gixy')
-rw-r--r--security/py-gixy/Makefile25
-rw-r--r--security/py-gixy/distinfo3
-rw-r--r--security/py-gixy/pkg-descr4
3 files changed, 32 insertions, 0 deletions
diff --git a/security/py-gixy/Makefile b/security/py-gixy/Makefile
new file mode 100644
index 000000000000..f93bc716b12f
--- /dev/null
+++ b/security/py-gixy/Makefile
@@ -0,0 +1,25 @@
+# Created by: Dan Langille
+# $FreeBSD$
+
+PORTNAME= gixy
+PORTVERSION= 0.1.3
+CATEGORIES= security www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= dvl@FreeBSD.org
+COMMENT= Tool to analyze Nginx configuration for security misconfiguration
+
+LICENSE= APACHE20
+
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pyparsing>=1.5.5:devel/py-pyparsing
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cached-property>=1.2.0:devel/py-cached-property
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}Jinja2>=2.8:devel/py-Jinja2
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}configargparse>=0.11.0:devel/py-configargparse
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-gixy/distinfo b/security/py-gixy/distinfo
new file mode 100644
index 000000000000..a6d95a5c0d27
--- /dev/null
+++ b/security/py-gixy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1494519770
+SHA256 (gixy-0.1.3.tar.gz) = bffb35c111807379eda3a4ea4da32587ad7368bc8fe7d5436dddb65037e39198
+SIZE (gixy-0.1.3.tar.gz) = 31484
diff --git a/security/py-gixy/pkg-descr b/security/py-gixy/pkg-descr
new file mode 100644
index 000000000000..8a70fa513d34
--- /dev/null
+++ b/security/py-gixy/pkg-descr
@@ -0,0 +1,4 @@
+Gixy is a tool to analyze Nginx configuration. The main goal of Gixy is to
+prevent security misconfiguration and automate flaw detection.
+
+WWW: https://github.com/yandex/gixy