aboutsummaryrefslogtreecommitdiff
path: root/security/py-gnutls
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-07 06:19:20 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2007-04-07 06:19:20 +0000
commite847b772c85d017da81f57c2c82538784aee88d0 (patch)
treed7081f8e8ec93ddb017ad4fed345236470a6b415 /security/py-gnutls
parent56ff2eef97270c9fa5ae3706ae50d923403fc5eb (diff)
Notes
Diffstat (limited to 'security/py-gnutls')
-rw-r--r--security/py-gnutls/Makefile41
-rw-r--r--security/py-gnutls/distinfo3
-rw-r--r--security/py-gnutls/pkg-descr17
-rw-r--r--security/py-gnutls/pkg-plist58
4 files changed, 119 insertions, 0 deletions
diff --git a/security/py-gnutls/Makefile b/security/py-gnutls/Makefile
new file mode 100644
index 000000000000..5fb4e257ea7e
--- /dev/null
+++ b/security/py-gnutls/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: py-gnutls
+# Date created: Apr. 06, 2007
+# Whom: Li-Wen Hsu <lwhsu@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnutls
+PORTVERSION= 1.0.0
+CATEGORIES= security python
+MASTER_SITES= http://cheeseshop.python.org/packages/source/p/python-gnutls/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-gnutls-${PORTVERSION}
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Python wrapper for the GNUTLS library
+
+LIB_DEPENDS= gnutls.15:${PORTSDIR}/security/gnutls
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+EXAMPLESDIR= ${TARGETDIR}/share/examples/py-${PORTNAME}
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|include_dirs=\[\]|include_dirs=\['${LOCALBASE}/include'\]|" ${WRKSRC}/setup.py
+ ${REINPLACE_CMD} -e "s|library_dirs=\[\]|library_dirs=\['${LOCALBASE}/lib'\]|" ${WRKSRC}/setup.py
+ ${FIND} ${WRKSRC}/gnutls/library -type f | ${XARGS} ${REINPLACE_CMD} -e 's/libgnutls.so.13/libgnutls.so.15/g'
+ ${FIND} ${WRKSRC}/gnutls/library -type f | ${XARGS} ${REINPLACE_CMD} -e 's/libgnutls-extra.so.13/libgnutls-extra.so.15/g'
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 250
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/ctypes/__init__.py:${PORTSDIR}/devel/py-ctypes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/py-gnutls/distinfo b/security/py-gnutls/distinfo
new file mode 100644
index 000000000000..2215a781708b
--- /dev/null
+++ b/security/py-gnutls/distinfo
@@ -0,0 +1,3 @@
+MD5 (python-gnutls-1.0.0.tar.gz) = 6353d852fd868248a23fac9cae0ccc0c
+SHA256 (python-gnutls-1.0.0.tar.gz) = c6ded4ee87349d36762b7934c243f0d42f5ae5a97161b11b3e69a97ac851d488
+SIZE (python-gnutls-1.0.0.tar.gz) = 40378
diff --git a/security/py-gnutls/pkg-descr b/security/py-gnutls/pkg-descr
new file mode 100644
index 000000000000..6ad6bd53fe19
--- /dev/null
+++ b/security/py-gnutls/pkg-descr
@@ -0,0 +1,17 @@
+This package provides a high level object oriented wrapper around libgnutls,
+as well as low level bindings to the GNUTLS types and functions via ctypes.
+The high level wrapper hides the details of accessing the GNUTLS library via
+ctypes behind a set of classes that encapsulate GNUTLS sessions, certificates
+and credentials and expose them to python applications using a simple API.
+
+The package also includes a Twisted interface that has seamless intergration
+with Twisted, providing connectTLS and listenTLS methods on the Twisted
+reactor once imported (the methods are automatically attached to the reactor
+by simply importing the GNUTLS Twisted interface module).
+
+The high level wrapper is written using the GNUTLS library bindings that are
+made available via ctypes. This makes the wrapper very powerful and flexible
+as it has direct access to all the GNUTLS internals and is also very easy to
+extend without any need to write C code or recompile anything.
+
+WWW: http://cheeseshop.python.org/pypi/python-gnutls/
diff --git a/security/py-gnutls/pkg-plist b/security/py-gnutls/pkg-plist
new file mode 100644
index 000000000000..99cacb7919ce
--- /dev/null
+++ b/security/py-gnutls/pkg-plist
@@ -0,0 +1,58 @@
+%%PYTHON_SITELIBDIR%%/gnutls/__init__.py
+%%PYTHON_SITELIBDIR%%/gnutls/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/connection.py
+%%PYTHON_SITELIBDIR%%/gnutls/connection.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/connection.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/constants.py
+%%PYTHON_SITELIBDIR%%/gnutls/constants.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/constants.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/crypto.py
+%%PYTHON_SITELIBDIR%%/gnutls/crypto.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/crypto.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/errors.py
+%%PYTHON_SITELIBDIR%%/gnutls/errors.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/errors.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/interfaces/__init__.py
+%%PYTHON_SITELIBDIR%%/gnutls/interfaces/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/interfaces/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/interfaces/twisted/__init__.py
+%%PYTHON_SITELIBDIR%%/gnutls/interfaces/twisted/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/interfaces/twisted/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/library/__init__.py
+%%PYTHON_SITELIBDIR%%/gnutls/library/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/library/__init__.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/library/_gnutls_init.so
+%%PYTHON_SITELIBDIR%%/gnutls/library/constants.py
+%%PYTHON_SITELIBDIR%%/gnutls/library/constants.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/library/constants.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/library/errors.py
+%%PYTHON_SITELIBDIR%%/gnutls/library/errors.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/library/errors.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/library/functions.py
+%%PYTHON_SITELIBDIR%%/gnutls/library/functions.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/library/functions.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/library/types.py
+%%PYTHON_SITELIBDIR%%/gnutls/library/types.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/library/types.pyo
+%%PYTHON_SITELIBDIR%%/gnutls/validators.py
+%%PYTHON_SITELIBDIR%%/gnutls/validators.pyc
+%%PYTHON_SITELIBDIR%%/gnutls/validators.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/gnutls/library
+@dirrm %%PYTHON_SITELIBDIR%%/gnutls/interfaces/twisted
+@dirrm %%PYTHON_SITELIBDIR%%/gnutls/interfaces
+@dirrm %%PYTHON_SITELIBDIR%%/gnutls
+%%EXAMPLESDIR%%/README
+%%EXAMPLESDIR%%/certs/ca.pem
+%%EXAMPLESDIR%%/certs/crl.pem
+%%EXAMPLESDIR%%/certs/revoked.crt
+%%EXAMPLESDIR%%/certs/revoked.key
+%%EXAMPLESDIR%%/certs/valid.crt
+%%EXAMPLESDIR%%/certs/valid.key
+%%EXAMPLESDIR%%/client.py
+%%EXAMPLESDIR%%/crypto.py
+%%EXAMPLESDIR%%/server.py
+%%EXAMPLESDIR%%/twisted-client.py
+%%EXAMPLESDIR%%/twisted-server.py
+@dirrm %%EXAMPLESDIR%%/certs
+@dirrm %%EXAMPLESDIR%%