aboutsummaryrefslogtreecommitdiff
path: root/security/py-google-auth-httplib2
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-09-10 20:26:36 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-09-10 20:26:36 +0000
commitf81b7391b5b59bb66c76dc487bf6b45a5900ef8d (patch)
treea9be033a0b0d6ce71f79f594de09451d2b03fadb /security/py-google-auth-httplib2
parent29356cfc9f03194140c568520fa4edd44f82fd48 (diff)
downloadports-f81b7391b5b59bb66c76dc487bf6b45a5900ef8d.tar.gz
ports-f81b7391b5b59bb66c76dc487bf6b45a5900ef8d.zip
Notes
Diffstat (limited to 'security/py-google-auth-httplib2')
-rw-r--r--security/py-google-auth-httplib2/Makefile24
-rw-r--r--security/py-google-auth-httplib2/distinfo3
-rw-r--r--security/py-google-auth-httplib2/pkg-descr3
3 files changed, 30 insertions, 0 deletions
diff --git a/security/py-google-auth-httplib2/Makefile b/security/py-google-auth-httplib2/Makefile
new file mode 100644
index 000000000000..4cb4d6236d07
--- /dev/null
+++ b/security/py-google-auth-httplib2/Makefile
@@ -0,0 +1,24 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= google-auth-httplib2
+PORTVERSION= 0.0.3
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Google Authentication Library: httplib2 transport
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}google-auth>=0:security/py-google-auth@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httplib2>=0.9.1:www/py-httplib2@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-google-auth-httplib2/distinfo b/security/py-google-auth-httplib2/distinfo
new file mode 100644
index 000000000000..c8247f42ef48
--- /dev/null
+++ b/security/py-google-auth-httplib2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1536608059
+SHA256 (google-auth-httplib2-0.0.3.tar.gz) = 098fade613c25b4527b2c08fa42d11f3c2037dda8995d86de0745228e965d445
+SIZE (google-auth-httplib2-0.0.3.tar.gz) = 9957
diff --git a/security/py-google-auth-httplib2/pkg-descr b/security/py-google-auth-httplib2/pkg-descr
new file mode 100644
index 000000000000..587ee3c54c19
--- /dev/null
+++ b/security/py-google-auth-httplib2/pkg-descr
@@ -0,0 +1,3 @@
+This library provides an httplib2 transport for google-auth.
+
+WWW: https://github.com/GoogleCloudPlatform/google-auth-library-python-httplib2