aboutsummaryrefslogtreecommitdiff
path: root/security/py-keepkey
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2019-02-02 11:59:05 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2019-02-02 11:59:05 +0000
commit52aa2d6b17fb14f35e34adf6081122369f84fcdb (patch)
tree1ad59fa2ed601540e6e45e0f339b31fb0941dd50 /security/py-keepkey
parent8ff0a142771788fa96cda69a76731ee0035f1cd6 (diff)
downloadports-52aa2d6b17fb14f35e34adf6081122369f84fcdb.tar.gz
ports-52aa2d6b17fb14f35e34adf6081122369f84fcdb.zip
Notes
Diffstat (limited to 'security/py-keepkey')
-rw-r--r--security/py-keepkey/Makefile26
-rw-r--r--security/py-keepkey/distinfo3
-rw-r--r--security/py-keepkey/pkg-descr3
3 files changed, 32 insertions, 0 deletions
diff --git a/security/py-keepkey/Makefile b/security/py-keepkey/Makefile
new file mode 100644
index 000000000000..7fa572e148ff
--- /dev/null
+++ b/security/py-keepkey/Makefile
@@ -0,0 +1,26 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= keepkey
+PORTVERSION= 6.0.2
+CATEGORIES= security
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Library for communicating with KeepKey Hardware Wallet
+
+LICENSE= LGPL3
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ecdsa>=0.9:security/py-ecdsa@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=3.0.0:devel/py-protobuf@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mnemonic>=0.8:security/py-mnemonic@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hidapi>=0.7.99.post15:comms/py-hidapi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}libusb1>=1.6:devel/py-libusb1@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-keepkey/distinfo b/security/py-keepkey/distinfo
new file mode 100644
index 000000000000..4bfcc7c9fc45
--- /dev/null
+++ b/security/py-keepkey/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1549099428
+SHA256 (keepkey-6.0.2.tar.gz) = af107f610fb0e2417fc7a9d87a2fa22aac9b80b79559370d178be424bb85489a
+SIZE (keepkey-6.0.2.tar.gz) = 147774
diff --git a/security/py-keepkey/pkg-descr b/security/py-keepkey/pkg-descr
new file mode 100644
index 000000000000..d001bf901410
--- /dev/null
+++ b/security/py-keepkey/pkg-descr
@@ -0,0 +1,3 @@
+Python library for communicating with KeepKey Hardware Wallet.
+
+WWW: https://github.com/keepkey/python-keepkey