aboutsummaryrefslogtreecommitdiff
path: root/security/py-keyring
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-06-09 16:48:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-06-09 16:48:39 +0000
commit17711897e9e24745221eb39e5c703c67e40861ca (patch)
tree83a6f74237c3873c5d0ab640d483ba9b1c346de7 /security/py-keyring
parent79284f653ffeacd4449c830a201c632502f13107 (diff)
downloadports-17711897e9e24745221eb39e5c703c67e40861ca.tar.gz
ports-17711897e9e24745221eb39e5c703c67e40861ca.zip
Notes
Diffstat (limited to 'security/py-keyring')
-rw-r--r--security/py-keyring/Makefile26
-rw-r--r--security/py-keyring/distinfo4
2 files changed, 23 insertions, 7 deletions
diff --git a/security/py-keyring/Makefile b/security/py-keyring/Makefile
index 7fc7abc27791..91c64322d843 100644
--- a/security/py-keyring/Makefile
+++ b/security/py-keyring/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= keyring
-PORTVERSION= 1.2.2
+PORTVERSION= 1.3
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -20,10 +20,14 @@ USE_ZIP= yes
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
-OPTIONS_DEFINE= CRYPT_FILE GNOME_KEYRING KDE_KWALLET
-GNOME_KEYRING_DESC= GNOME Keyring backend
-KDE_KWALLET_DESC= KDE KWallet backend
-CRYPT_FILE_DESC= Crypt(ed) File backend
+OPTIONS_DEFINE= CRYPT_FILE GNOME_KEYRING KDE_KWALLET KEYCZAR PYFS \
+ SECRET_SERVICE
+CRYPT_FILE_DESC= Install pycrpto to support the Crypt(ed) File backend
+GNOME_KEYRING_DESC= Install GNOME Keyring to support the Gnome backend
+KDE_KWALLET_DESC= Install KDE KWallet to support the kwallet backend
+KEYCZAR_DESC= Install keyczar to support keyring encryption
+PYFS_DESC= Install pyfilesystem to support the pyfs backend
+SECRET_SERVICE_DESC= Install SecretStorage to support the SecretService backend
.include <bsd.port.options.mk>
@@ -39,4 +43,16 @@ USE_GNOME+= pygnomedesktop
USE_KDE4+= pykde4
.endif
+.if ${PORT_OPTIONS:MKEYCZAR}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}keyczar>=0.71c:${PORTSDIR}/security/py-keyczar
+.endif
+
+.if ${PORT_OPTIONS:MPYFS}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}fs>=0.4.0:${PORTSDIR}/devel/py-fs
+.endif
+
+.if ${PORT_OPTIONS:MSECRET_SERVICE}
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}SecretStorage>=1.0.0:${PORTSDIR}/security/py-SecretStorage
+.endif
+
.include <bsd.port.mk>
diff --git a/security/py-keyring/distinfo b/security/py-keyring/distinfo
index 9ca230f6fc0d..9cf13437debd 100644
--- a/security/py-keyring/distinfo
+++ b/security/py-keyring/distinfo
@@ -1,2 +1,2 @@
-SHA256 (keyring-1.2.2.zip) = 20e4e34f15deca61d5a58edc1d2e5e3720cbdc340726d4918590036db6decfab
-SIZE (keyring-1.2.2.zip) = 79028
+SHA256 (keyring-1.3.zip) = 8f3a1936b241332289c6c3a7bef0f380de8cd34e7e90fd6b3bb11ff6d51bb961
+SIZE (keyring-1.3.zip) = 79451