aboutsummaryrefslogtreecommitdiff
path: root/security/py-keyring
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-04 21:04:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-04 21:04:44 +0000
commit24b4f66f4d95ae54d95af565d157beace9242b19 (patch)
tree15801134a5c7b74a628a6827ddce2f996958830d /security/py-keyring
parent7e194b6bbcc5d88c989cd31c5f8fc05429b6830e (diff)
downloadports-24b4f66f4d95ae54d95af565d157beace9242b19.tar.gz
ports-24b4f66f4d95ae54d95af565d157beace9242b19.zip
Notes
Diffstat (limited to 'security/py-keyring')
-rw-r--r--security/py-keyring/Makefile56
-rw-r--r--security/py-keyring/distinfo3
-rw-r--r--security/py-keyring/files/patch-extensions.py14
-rw-r--r--security/py-keyring/pkg-descr7
-rw-r--r--security/py-keyring/pkg-plist12
5 files changed, 92 insertions, 0 deletions
diff --git a/security/py-keyring/Makefile b/security/py-keyring/Makefile
new file mode 100644
index 000000000000..fa0a568b0eac
--- /dev/null
+++ b/security/py-keyring/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: py-keyring
+# Date created: 2 September 2009
+# Whom: Douglas Thrift
+#
+# $FreeBSD$
+#
+
+PORTNAME= keyring
+PORTVERSION= 0.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP \
+ http://code.douglasthrift.net/files/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= Store and access your passwords safely
+
+LATEST_LINK= py-${PORTNAME}
+
+USE_KDE4= #
+USE_PYTHON= 2.6+
+USE_PYDISTUTILS= yes
+
+OPTIONS= GNOME_KEYRING "GNOME Keyring backend" Off \
+ KDE_KWALLET "KDE KWallet backend" Off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GNOME_KEYRING)
+LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/gnome-keyring
+PLIST_SUB+= GNOME_KEYRING=""
+.else
+PLIST_SUB+= GNOME_KEYRING="@comment "
+.endif
+
+.if defined(WITH_KDE_KWALLET)
+PLIST_SUB+= KDE_KWALLET=""
+USE_KDE4+= kdelibs
+.else
+PLIST_SUB+= KDE_KWALLET="@comment "
+.endif
+
+post-patch:
+.if !defined(WITH_GNOME_KEYRING)
+ @${REINPLACE_CMD} -e 's|exts\.append(gnome_keychain_module)|#&|' \
+ ${WRKSRC}/extensions.py
+.endif
+.if defined(WITH_KDE_KWALLET)
+ @${REINPLACE_CMD} -e 's|kde4-config|${KDE4_PREFIX}/bin/kde4-config|' \
+ ${WRKSRC}/extensions.py
+.else
+ @${REINPLACE_CMD} -e 's|exts\.append(kde_kwallet_module)|#&|' \
+ ${WRKSRC}/extensions.py
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/py-keyring/distinfo b/security/py-keyring/distinfo
new file mode 100644
index 000000000000..b0f5e76106ed
--- /dev/null
+++ b/security/py-keyring/distinfo
@@ -0,0 +1,3 @@
+MD5 (keyring-0.1.tar.gz) = e593725919ed00a631c4348d08c77f56
+SHA256 (keyring-0.1.tar.gz) = c5e19bfd138034a8d3193a5c5314493e51a90a0c4bb78db87c0a0451aa7327a8
+SIZE (keyring-0.1.tar.gz) = 14468
diff --git a/security/py-keyring/files/patch-extensions.py b/security/py-keyring/files/patch-extensions.py
new file mode 100644
index 000000000000..00cf9b75147a
--- /dev/null
+++ b/security/py-keyring/files/patch-extensions.py
@@ -0,0 +1,14 @@
+--- extensions.py.orig 2009-08-21 09:34:01.000000000 -0700
++++ extensions.py 2009-09-03 15:43:41.224189815 -0700
+@@ -42,9 +42,9 @@
+
+ keywords.setdefault('libraries', []).append('kdeui')
+ libs = commands.getoutput("kde4-config --path lib").split(':')
+- if len(libs) == 0:
+- libs = commands.getoutput("kde-config --path lib").split(':')
+ keywords.setdefault('library_dirs', []).extend(libs)
++ includes = commands.getoutput("kde4-config --install include").split(':')
++ keywords.setdefault('include_dirs', []).extend(includes)
+ return keywords
+
+ def get_extensions():
diff --git a/security/py-keyring/pkg-descr b/security/py-keyring/pkg-descr
new file mode 100644
index 000000000000..cea6c28b4161
--- /dev/null
+++ b/security/py-keyring/pkg-descr
@@ -0,0 +1,7 @@
+The Python keyring lib provides an easy way to access the system keyring
+service from Python. It can be used in any application that needs safe password
+storage. It supports OSX, KDE, Gnome and Windows's native password storing
+services. Besides this, it is shipped with kinds of Python implemented keyring
+for the left environments.
+
+WWW: http://pypi.python.org/pypi/keyring
diff --git a/security/py-keyring/pkg-plist b/security/py-keyring/pkg-plist
new file mode 100644
index 000000000000..437a2c6991d8
--- /dev/null
+++ b/security/py-keyring/pkg-plist
@@ -0,0 +1,12 @@
+%%GNOME_KEYRING%%%%PYTHON_SITELIBDIR%%/gnome_keyring.so
+%%KDE_KWALLET%%%%PYTHON_SITELIBDIR%%/kde_kwallet.so
+%%PYTHON_SITELIBDIR%%/keyring/__init__.py
+%%PYTHON_SITELIBDIR%%/keyring/__init__.pyc
+%%PYTHON_SITELIBDIR%%/keyring/__init__.pyo
+%%PYTHON_SITELIBDIR%%/keyring/backend.py
+%%PYTHON_SITELIBDIR%%/keyring/backend.pyc
+%%PYTHON_SITELIBDIR%%/keyring/backend.pyo
+%%PYTHON_SITELIBDIR%%/keyring/core.py
+%%PYTHON_SITELIBDIR%%/keyring/core.pyc
+%%PYTHON_SITELIBDIR%%/keyring/core.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/keyring