aboutsummaryrefslogtreecommitdiff
path: root/security/py-keyrings.alt
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-02-12 21:03:10 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-02-12 21:03:10 +0000
commit74aa54bc02f752676d222fc333635a306017ab6f (patch)
treeb53ef9ebf523c5d10022f13a56a3def1fe7d2296 /security/py-keyrings.alt
parenteddef5253586177747539d54b99807f061bc9ce4 (diff)
downloadports-74aa54bc02f752676d222fc333635a306017ab6f.tar.gz
ports-74aa54bc02f752676d222fc333635a306017ab6f.zip
Notes
Diffstat (limited to 'security/py-keyrings.alt')
-rw-r--r--security/py-keyrings.alt/Makefile34
-rw-r--r--security/py-keyrings.alt/distinfo2
-rw-r--r--security/py-keyrings.alt/pkg-descr4
3 files changed, 40 insertions, 0 deletions
diff --git a/security/py-keyrings.alt/Makefile b/security/py-keyrings.alt/Makefile
new file mode 100644
index 000000000000..6f3e58722a49
--- /dev/null
+++ b/security/py-keyrings.alt/Makefile
@@ -0,0 +1,34 @@
+# Created by: Douglas Thrift <douglas@douglasthrift.net>
+# $FreeBSD$
+
+PORTNAME= keyrings.alt
+PORTVERSION= 1.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= douglas@douglasthrift.net
+COMMENT= Alternate Python keyring implementations
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=1.9:${PORTSDIR}/devel/py-setuptools_scm
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= autoplist distutils
+
+OPTIONS_DEFINE= ENCRYPTED_FILE GNOME_KEYRING KDE_KWALLET KEYCZAR PYFS
+ENCRYPTED_FILE_DESC= Install pycrypto to support the Encrypted File backend
+GNOME_KEYRING_DESC= Install GNOME Keyring to support the Gnome backend
+KDE_KWALLET_DESC= Install KDE KWallet to support the kwallet backend
+KEYCZAR_DESC= Install keyczar to support keyring encryption
+PYFS_DESC= Install pyfilesystem to support the pyfs backend
+
+ENCRYPTED_FILE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.5:${PORTSDIR}/security/py-pycrypto
+GNOME_KEYRING_USE= GNOME=pygobject3
+KDE_KWALLET_USE= KDE4=pykde4
+KEYCZAR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}keyczar>=0.71c:${PORTSDIR}/security/py-keyczar
+PYFS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}fs>=0.5:${PORTSDIR}/devel/py-fs
+
+.include <bsd.port.mk>
diff --git a/security/py-keyrings.alt/distinfo b/security/py-keyrings.alt/distinfo
new file mode 100644
index 000000000000..10e946a6f675
--- /dev/null
+++ b/security/py-keyrings.alt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (keyrings.alt-1.1.tar.gz) = dc3b3ad7d34f22744de75bfcbeb608445aaf059ff4bb28bf2247de8372be207b
+SIZE (keyrings.alt-1.1.tar.gz) = 21520
diff --git a/security/py-keyrings.alt/pkg-descr b/security/py-keyrings.alt/pkg-descr
new file mode 100644
index 000000000000..957fe4854354
--- /dev/null
+++ b/security/py-keyrings.alt/pkg-descr
@@ -0,0 +1,4 @@
+Alternate keyring backend implementations for use with the Python keyring
+package.
+
+WWW: https://pypi.python.org/pypi/keyrings.alt