aboutsummaryrefslogtreecommitdiff
path: root/security/py-m2crypto/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-11-04 20:11:35 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-11-04 20:11:35 +0000
commit331aef55a4af3377d367006cb7ad5c6b143e3643 (patch)
treee71c36f4ba7a92054524d51b662081ff49795030 /security/py-m2crypto/Makefile
parent6c8a67154e30aef422d1c1565e1c637eee51dc8f (diff)
downloadports-331aef55a4af3377d367006cb7ad5c6b143e3643.tar.gz
ports-331aef55a4af3377d367006cb7ad5c6b143e3643.zip
- Update to 0.22.5
- Update BUILD_DEPENDS: remove redundant LOCALBASE/bin and use newer swig - Strip shared library - Update WWW Changes: https://gitlab.com/m2crypto/m2crypto/tags
Notes
Notes: svn path=/head/; revision=400765
Diffstat (limited to 'security/py-m2crypto/Makefile')
-rw-r--r--security/py-m2crypto/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/security/py-m2crypto/Makefile b/security/py-m2crypto/Makefile
index 84ee1863092e..505ee819b83e 100644
--- a/security/py-m2crypto/Makefile
+++ b/security/py-m2crypto/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= m2crypto
-PORTVERSION= 0.22.3
+PORTVERSION= 0.22.5
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,11 +13,18 @@ COMMENT= Crypto and SSL toolkit for Python
LICENSE= MIT
-BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+BUILD_DEPENDS= swig3.0:${PORTSDIR}/devel/swig30
-PYDISTUTILS_BUILDARGS= build_ext --openssl="${OPENSSLBASE}"
+PYDISTUTILS_BUILDARGS= build_ext --openssl=${OPENSSLBASE} --swig=${LOCALBASE}/bin/swig3.0
USE_OPENSSL= yes
USE_PYTHON= autoplist distutils
USES= python:2
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/M2Crypto/_m2crypto.py \
+ %%PYTHON_SITELIBDIR%%/M2Crypto/_m2crypto.pyc \
+ %%PYTHON_SITELIBDIR%%/M2Crypto/_m2crypto.pyo
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/M2Crypto/__m2crypto.so
+
.include <bsd.port.mk>