aboutsummaryrefslogtreecommitdiff
path: root/security/py-m2crypto
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-08-06 08:46:45 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-08-06 08:46:45 +0000
commit7e6e9ca46eadda3043add7b5ba9b35c1e5f069b1 (patch)
tree186b56b85b27d5ad00b0db256770a459b6ff6cdb /security/py-m2crypto
parent248db8434ac1696eb8b68281705b7aec6da0d0cf (diff)
downloadports-7e6e9ca46eadda3043add7b5ba9b35c1e5f069b1.tar.gz
ports-7e6e9ca46eadda3043add7b5ba9b35c1e5f069b1.zip
Notes
Diffstat (limited to 'security/py-m2crypto')
-rw-r--r--security/py-m2crypto/Makefile4
-rw-r--r--security/py-m2crypto/files/patch-SWIG::Makefile11
2 files changed, 10 insertions, 5 deletions
diff --git a/security/py-m2crypto/Makefile b/security/py-m2crypto/Makefile
index 6ea55f140bd8..c6e982efce9a 100644
--- a/security/py-m2crypto/Makefile
+++ b/security/py-m2crypto/Makefile
@@ -23,9 +23,13 @@ WRKSRC= ${WRKDIR}/${DISTNAME}/SWIG
USE_PYTHON= yes
USE_ZIP= yes
USE_OPENSSL= yes
+USE_REINPLACE= yes
PINSTALL_PLIST= ${WRKDIR}/pinstall-plist
+post-patch:
+ ${REINPLACE_CMD} "s/PYTHON_VERSION/${PYTHON_VERSION}/" ${WRKSRC}/Makefile
+
post-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/../M2Crypto
diff --git a/security/py-m2crypto/files/patch-SWIG::Makefile b/security/py-m2crypto/files/patch-SWIG::Makefile
index 59ec0a7a492b..e6d34ff9d941 100644
--- a/security/py-m2crypto/files/patch-SWIG::Makefile
+++ b/security/py-m2crypto/files/patch-SWIG::Makefile
@@ -1,11 +1,12 @@
---- Makefile.orig Wed Aug 6 16:47:51 2003
-+++ Makefile Wed Aug 6 16:49:15 2003
-@@ -3,7 +3,7 @@
+--- Makefile.orig Wed Aug 6 17:33:10 2003
++++ Makefile Wed Aug 6 17:34:04 2003
+@@ -3,8 +3,7 @@
CFLAGS = -DTHREADING -g
INCLUDE = -I/usr/local/include -I.
LIBS = -L/usr/local/lib -lssl -lcrypto
-PYVER = 2.2
-+PYVER = 2.3
- PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/python$(PYVER) \
+-PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/python$(PYVER) \
++PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/PYTHON_VERSION \
-I/usr/local/lib/python$(PYVER)/config
PYLIB = /usr/local/lib/python$(PYVER)/config
+