aboutsummaryrefslogtreecommitdiff
path: root/security/py-m2crypto
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-11-04 20:11:35 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-11-04 20:11:35 +0000
commit331aef55a4af3377d367006cb7ad5c6b143e3643 (patch)
treee71c36f4ba7a92054524d51b662081ff49795030 /security/py-m2crypto
parent6c8a67154e30aef422d1c1565e1c637eee51dc8f (diff)
downloadports-331aef55a4af3377d367006cb7ad5c6b143e3643.tar.gz
ports-331aef55a4af3377d367006cb7ad5c6b143e3643.zip
Notes
Diffstat (limited to 'security/py-m2crypto')
-rw-r--r--security/py-m2crypto/Makefile13
-rw-r--r--security/py-m2crypto/distinfo4
-rw-r--r--security/py-m2crypto/pkg-descr2
3 files changed, 13 insertions, 6 deletions
diff --git a/security/py-m2crypto/Makefile b/security/py-m2crypto/Makefile
index 84ee1863092e..505ee819b83e 100644
--- a/security/py-m2crypto/Makefile
+++ b/security/py-m2crypto/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= m2crypto
-PORTVERSION= 0.22.3
+PORTVERSION= 0.22.5
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,11 +13,18 @@ COMMENT= Crypto and SSL toolkit for Python
LICENSE= MIT
-BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+BUILD_DEPENDS= swig3.0:${PORTSDIR}/devel/swig30
-PYDISTUTILS_BUILDARGS= build_ext --openssl="${OPENSSLBASE}"
+PYDISTUTILS_BUILDARGS= build_ext --openssl=${OPENSSLBASE} --swig=${LOCALBASE}/bin/swig3.0
USE_OPENSSL= yes
USE_PYTHON= autoplist distutils
USES= python:2
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/M2Crypto/_m2crypto.py \
+ %%PYTHON_SITELIBDIR%%/M2Crypto/_m2crypto.pyc \
+ %%PYTHON_SITELIBDIR%%/M2Crypto/_m2crypto.pyo
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/M2Crypto/__m2crypto.so
+
.include <bsd.port.mk>
diff --git a/security/py-m2crypto/distinfo b/security/py-m2crypto/distinfo
index 4f953f3f4785..ed11197870b3 100644
--- a/security/py-m2crypto/distinfo
+++ b/security/py-m2crypto/distinfo
@@ -1,2 +1,2 @@
-SHA256 (M2Crypto-0.22.3.tar.gz) = 6071bfc817d94723e9b458a010d565365104f84aa73f7fe11919871f7562ff72
-SIZE (M2Crypto-0.22.3.tar.gz) = 74795
+SHA256 (M2Crypto-0.22.5.tar.gz) = b5ce9b09062a2c453e9d9c28dde96b7f90834313e60f419b143d751eb4109fdc
+SIZE (M2Crypto-0.22.5.tar.gz) = 80986
diff --git a/security/py-m2crypto/pkg-descr b/security/py-m2crypto/pkg-descr
index 7cb73323b3e8..1cebbe8da839 100644
--- a/security/py-m2crypto/pkg-descr
+++ b/security/py-m2crypto/pkg-descr
@@ -6,4 +6,4 @@ client and server; S/MIME; ZServerSSL: A HTTPS server for Zope and ZSmime: An
S/MIME messenger for Zope.
WWW: https://pypi.python.org/pypi/M2Crypto
-WWW: http://chandlerproject.org/Projects/MeTooCrypto
+WWW: https://gitlab.com/m2crypto/m2crypto