aboutsummaryrefslogtreecommitdiff
path: root/security/py-mhash/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-10 19:29:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-10 19:29:58 +0000
commitfcb91f804e46baa475423e9c5954201a88675168 (patch)
tree3ede5b6742d4f6c773188dd3fc27947a97d13955 /security/py-mhash/Makefile
parente67c886b3371e7060f4a99bab6d62bf4071f49ed (diff)
add py-mhash 1.0
Python mhash module
Notes
Notes: svn path=/head/; revision=54494
Diffstat (limited to 'security/py-mhash/Makefile')
-rw-r--r--security/py-mhash/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/security/py-mhash/Makefile b/security/py-mhash/Makefile
new file mode 100644
index 000000000000..fc15080a1826
--- /dev/null
+++ b/security/py-mhash/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: py-mhash
+# Date created: Feb 10, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= mhash
+PORTVERSION= 1.0
+CATEGORIES= security python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= mhash
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= python-mhash-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= mhash:${PORTSDIR}/security/mhash
+
+USE_PYTHON= yes
+CFLAGS+= -I${LOCALBASE}/include
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build_ext -L${LOCALBASE}/lib
+
+do-install:
+ @${SETUP_CMD} install
+
+.include <bsd.port.mk>