aboutsummaryrefslogtreecommitdiff
path: root/security/py-oauth2client/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-10-06 23:08:26 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-10-06 23:08:26 +0000
commit9588594094032e2df13f60ad4606dd6a31f65096 (patch)
treee5199eb70f17533b13aaf715bf50bf1b2002160a /security/py-oauth2client/Makefile
parentc2a1b001682b30c59ff4dd89388fb6a55bddf886 (diff)
downloadports-9588594094032e2df13f60ad4606dd6a31f65096.tar.gz
ports-9588594094032e2df13f60ad4606dd6a31f65096.zip
- Add py-oauth2client 1.3
oauth2client is a Python module for client-side oauth2 authentication. It works with Google's oauth2 service by default, and is compatible with any oauth2 service. WWW: https://pypi.python.org/pypi/oauth2client WWW: http://google.github.io/oauth2client/
Notes
Notes: svn path=/head/; revision=370257
Diffstat (limited to 'security/py-oauth2client/Makefile')
-rw-r--r--security/py-oauth2client/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/security/py-oauth2client/Makefile b/security/py-oauth2client/Makefile
new file mode 100644
index 000000000000..cbc09bbc47fb
--- /dev/null
+++ b/security/py-oauth2client/Makefile
@@ -0,0 +1,20 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= oauth2client
+PORTVERSION= 1.3
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= OAuth 2.0 client library
+
+LICENSE= APACHE20
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httplib2>=0.8:${PORTSDIR}/www/py-httplib2
+
+USE_PYTHON= autoplist distutils
+USES= python:2
+
+.include <bsd.port.mk>