aboutsummaryrefslogtreecommitdiff
path: root/security/py-openssl/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-11 14:54:44 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-11 14:54:44 +0000
commit3d883b3a8872dbdfb4b42629815f8c07cb3e09b2 (patch)
treeda59431155fd36e92a631abf82d9ec95d23730b4 /security/py-openssl/Makefile
parentb140243697f05bcb9ecd8441b26df95f67fdf544 (diff)
Notes
Diffstat (limited to 'security/py-openssl/Makefile')
-rw-r--r--security/py-openssl/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/security/py-openssl/Makefile b/security/py-openssl/Makefile
new file mode 100644
index 000000000000..703488d58b00
--- /dev/null
+++ b/security/py-openssl/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: py-openssl
+# Date created: Feb 10, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= openssl
+PORTVERSION= 0.4.1
+CATEGORIES= security python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pyopenssl
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyOpenSSL-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+USE_OPENSSL= yes
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+
+.include <bsd.port.mk>