aboutsummaryrefslogtreecommitdiff
path: root/security/py-paramiko/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-12-08 10:01:41 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-12-08 10:01:41 +0000
commitc62af3a812cf69a132918ea25a0f1ce6ff5a4c17 (patch)
treed24de90a39891397c683b10b054d1377d4bf58dd /security/py-paramiko/Makefile
parentd8682a211857575657da76b1e8fd59004430a22f (diff)
Notes
Diffstat (limited to 'security/py-paramiko/Makefile')
-rw-r--r--security/py-paramiko/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/security/py-paramiko/Makefile b/security/py-paramiko/Makefile
index 3a20a2a662ca..1221bdafa051 100644
--- a/security/py-paramiko/Makefile
+++ b/security/py-paramiko/Makefile
@@ -6,12 +6,12 @@
#
PORTNAME= paramiko
-PORTVERSION= 1.7.5
+PORTVERSION= 1.7.6
CATEGORIES= security python
MASTER_SITES= http://www.lag.net/paramiko/download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= fullermd@over-yonder.net
+MAINTAINER= sbrabez@gmail.com
COMMENT= A python library for making SSH2 connections
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
@@ -19,4 +19,12 @@ RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pyc
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+.if !defined(NOPORTEXAMPLES)
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} ${WRKSRC}/demos/* ${EXAMPLESDIR}
+.endif
+
.include <bsd.port.mk>