aboutsummaryrefslogtreecommitdiff
path: root/security/py-paramiko
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2016-11-30 22:38:21 +0000
committerSofian Brabez <sbz@FreeBSD.org>2016-11-30 22:38:21 +0000
commit641274001cbfa0e8fa78a31a0b489891941f8282 (patch)
tree1d97ae06dd1ad251bd759886ef80880942c9a479 /security/py-paramiko
parentcbccebf2205df9fa09e9b358a27042c0176efcfc (diff)
Notes
Diffstat (limited to 'security/py-paramiko')
-rw-r--r--security/py-paramiko/Makefile8
-rw-r--r--security/py-paramiko/distinfo6
-rw-r--r--security/py-paramiko/files/patch-tests_test__packetizer.py11
3 files changed, 18 insertions, 7 deletions
diff --git a/security/py-paramiko/Makefile b/security/py-paramiko/Makefile
index 938b898dcb1d..3e7b07b92935 100644
--- a/security/py-paramiko/Makefile
+++ b/security/py-paramiko/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= paramiko
-PORTVERSION= 2.0.0
-PORTREVISION= 1
+PORTVERSION= 2.0.2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,18 +11,19 @@ MAINTAINER= sbz@FreeBSD.org
COMMENT= Python SSH2 protocol library
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography \
${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa
USES= python
-USE_PYTHON= distutils autoplist
+USE_PYTHON= autoplist concurrent distutils
CONFLICTS_INSTALL= py??-paramiko1-*
OPTIONS_DEFINE= EXAMPLES
-regression-test: extract
+do-test: extract
@(cd ${WRKSRC} && ${PYTHON_CMD} test.py)
.include <bsd.port.mk>
diff --git a/security/py-paramiko/distinfo b/security/py-paramiko/distinfo
index 4b13f4d82c53..a76892aa44b5 100644
--- a/security/py-paramiko/distinfo
+++ b/security/py-paramiko/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1464139163
-SHA256 (paramiko-2.0.0.tar.gz) = 51219ecaf88aa1cea9952b3c4ddcc0c1316f015d23d77edb7aee78a3468ef0e2
-SIZE (paramiko-2.0.0.tar.gz) = 1372885
+TIMESTAMP = 1480541457
+SHA256 (paramiko-2.0.2.tar.gz) = 411bf90fa22b078a923ff19ef9772c1115a0953702db93549a2848acefd141dc
+SIZE (paramiko-2.0.2.tar.gz) = 1190464
diff --git a/security/py-paramiko/files/patch-tests_test__packetizer.py b/security/py-paramiko/files/patch-tests_test__packetizer.py
new file mode 100644
index 000000000000..3e6bd1aac340
--- /dev/null
+++ b/security/py-paramiko/files/patch-tests_test__packetizer.py
@@ -0,0 +1,11 @@
+--- tests/test_packetizer.py.orig 2016-11-30 22:24:28 UTC
++++ tests/test_packetizer.py
+@@ -114,7 +114,7 @@ class PacketizerTest (unittest.TestCase)
+ class TimeoutError(Exception):
+ pass
+
+- def timeout(seconds=1, error_message=os.strerror(errno.ETIME)):
++ def timeout(seconds=1, error_message='Timer expired'):
+ def decorator(func):
+ def _handle_timeout(signum, frame):
+ raise TimeoutError(error_message)