aboutsummaryrefslogtreecommitdiff
path: root/security/py-paramiko
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2012-10-03 11:07:31 +0000
committerSofian Brabez <sbz@FreeBSD.org>2012-10-03 11:07:31 +0000
commit8be1420b3fe6ce20e1a79f29d8088375a327d4d3 (patch)
tree571e8246eccc6d6e34468b7c97395d1f317ba342 /security/py-paramiko
parent542ed8bc1668c8231fe01109f6dbf4aea3a4e627 (diff)
downloadports-8be1420b3fe6ce20e1a79f29d8088375a327d4d3.tar.gz
ports-8be1420b3fe6ce20e1a79f29d8088375a327d4d3.zip
Notes
Diffstat (limited to 'security/py-paramiko')
-rw-r--r--security/py-paramiko/Makefile11
-rw-r--r--security/py-paramiko/distinfo4
-rw-r--r--security/py-paramiko/files/patch-setup.py11
-rw-r--r--security/py-paramiko/pkg-plist1
4 files changed, 11 insertions, 16 deletions
diff --git a/security/py-paramiko/Makefile b/security/py-paramiko/Makefile
index 251ea68b2878..a0b4cecc73be 100644
--- a/security/py-paramiko/Makefile
+++ b/security/py-paramiko/Makefile
@@ -1,12 +1,8 @@
-# Ports collection makefile for: paramiko
-# Date created: 4 Feb 2006
-# Whom: Ulf Lilleengen
-#
+# Created by: Ulf Lilleengen
# $FreeBSD$
-#
PORTNAME= paramiko
-PORTVERSION= 1.7.7.2
+PORTVERSION= 1.8.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,7 +11,6 @@ MAINTAINER= sbz@FreeBSD.org
COMMENT= A python library for making SSH2 connections
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto
@@ -30,7 +25,7 @@ post-install:
@(cd ${WRKSRC}/demos && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
-regression-test:
+regression-test: build
@(cd ${WRKSRC} && ${PYTHON_CMD} test.py)
.include <bsd.port.mk>
diff --git a/security/py-paramiko/distinfo b/security/py-paramiko/distinfo
index f4fd3a7e6814..aff0180d4ef9 100644
--- a/security/py-paramiko/distinfo
+++ b/security/py-paramiko/distinfo
@@ -1,2 +1,2 @@
-SHA256 (paramiko-1.7.7.2.tar.gz) = 576f63f4d109450afe8c11a8fb4796cd3b7ebe47e938a427a39b6e5e5e7aa4c0
-SIZE (paramiko-1.7.7.2.tar.gz) = 821072
+SHA256 (paramiko-1.8.0.tar.gz) = dcdb8fa3059bf58ca7e3801a51df5d1707159b366ec0c0c7c2bb9008d08800f8
+SIZE (paramiko-1.8.0.tar.gz) = 809025
diff --git a/security/py-paramiko/files/patch-setup.py b/security/py-paramiko/files/patch-setup.py
index e96eebc23bac..5ab4a79f3140 100644
--- a/security/py-paramiko/files/patch-setup.py
+++ b/security/py-paramiko/files/patch-setup.py
@@ -1,20 +1,19 @@
---- ./setup.py.orig 2011-05-31 12:57:26.000000000 +0200
-+++ ./setup.py 2011-05-31 13:01:30.000000000 +0200
-@@ -33,14 +33,9 @@
+--- ./setup.py.orig 2012-10-03 11:45:35.000000000 +0200
++++ ./setup.py 2012-10-03 11:46:32.000000000 +0200
+@@ -37,14 +37,8 @@
#ez_setup.use_setuptools()
import sys
-try:
- from setuptools import setup
- kw = {
-- 'install_requires': 'pycrypto >= 2.1',
+- 'install_requires': 'pycrypto >= 2.1, != 2.4',
- }
-except ImportError:
- from distutils.core import setup
- kw = {}
-+
+from distutils.core import setup
+kw = {}
if sys.platform == 'darwin':
- import setup_helper
+ import setup_helper
diff --git a/security/py-paramiko/pkg-plist b/security/py-paramiko/pkg-plist
index 599871e36ed1..98e2f230009e 100644
--- a/security/py-paramiko/pkg-plist
+++ b/security/py-paramiko/pkg-plist
@@ -105,6 +105,7 @@
%%PYTHON_SITELIBDIR%%/paramiko/win_pageant.pyo
@dirrm %%PYTHON_SITELIBDIR%%/paramiko
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo_keygen.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo_server.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo_sftp.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/demo_simple.py