aboutsummaryrefslogtreecommitdiff
path: root/security/py-posix1e/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-12-17 16:48:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-12-17 16:48:24 +0000
commitbcccd64f743c9f96dfd398cc7f0c1c726c659021 (patch)
treef8832ba4bb8956ed0bbcd967f88db5a50748be75 /security/py-posix1e/Makefile
parentf6460b1dae9b6e04b36011af0ff60ef8d0955ba1 (diff)
downloadports-bcccd64f743c9f96dfd398cc7f0c1c726c659021.tar.gz
ports-bcccd64f743c9f96dfd398cc7f0c1c726c659021.zip
Notes
Diffstat (limited to 'security/py-posix1e/Makefile')
-rw-r--r--security/py-posix1e/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/security/py-posix1e/Makefile b/security/py-posix1e/Makefile
index f5c00c6e1379..ccb379948202 100644
--- a/security/py-posix1e/Makefile
+++ b/security/py-posix1e/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= posix1e
-PORTVERSION= 0.2.1
+PORTVERSION= 0.4.0
CATEGORIES= security python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= pylibacl
@@ -17,18 +17,21 @@ MAINTAINER= perky@FreeBSD.org
COMMENT= Python module for manipulating POSIX.1e ACLs
USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS= easy_install
PYDISTUTILS_PKGNAME= pylibacl
+PYEASYINSTALL_ARCHDEP= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
+
+PORTDOCS= COPYING IMPLEMENTATION NEWS PLATFORMS README
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
.include <bsd.port.pre.mk>
-post-patch:
- ${REINPLACE_CMD} -e \
- 's,/usr/share/doc/pylibacl,${PREFIX}/share/doc/py-posix1e,g' \
- ${WRKSRC}/setup.py
-.if ${OSVERSION} >= 500038
- ${REINPLACE_CMD} -e 's,^.*libs.append.*posix1e.*$$,,g' \
- ${WRKSRC}/setup.py
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
.include <bsd.port.post.mk>