aboutsummaryrefslogtreecommitdiff
path: root/security/py-posix1e
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2003-01-02 06:07:56 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2003-01-02 06:07:56 +0000
commitf54221f7b8f473e48b983bcff48b1535f4869e39 (patch)
tree833bb44ddda097ebbffa66233a922a6c7879e379 /security/py-posix1e
parent66a703c5bbfe3e194a62080e8c83dddda09f4daa (diff)
downloadports-f54221f7b8f473e48b983bcff48b1535f4869e39.tar.gz
ports-f54221f7b8f473e48b983bcff48b1535f4869e39.zip
Notes
Diffstat (limited to 'security/py-posix1e')
-rw-r--r--security/py-posix1e/Makefile33
-rw-r--r--security/py-posix1e/distinfo1
-rw-r--r--security/py-posix1e/pkg-comment1
-rw-r--r--security/py-posix1e/pkg-descr3
-rw-r--r--security/py-posix1e/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/security/py-posix1e/Makefile b/security/py-posix1e/Makefile
new file mode 100644
index 000000000000..9171e44630f3
--- /dev/null
+++ b/security/py-posix1e/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: py-posix1e
+# Date created: 2 January 2003
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+#
+
+PORTNAME= posix1e
+PORTVERSION= 0.2.1
+CATEGORIES= security python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pylibacl
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pylibacl-${PORTVERSION}
+
+MAINTAINER= perky@FreeBSD.org
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_REINPLACE= yes
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e \
+ 's,/usr/share/doc/pylibacl,${PREFIX}/share/doc/py-posix1e,g' \
+ ${WRKSRC}/setup.py
+.if ${OSVERSION} >= 500038
+ ${REINPLACE_CMD} -e 's,^.*libs.append.*posix1e.*$$,,g' \
+ ${WRKSRC}/setup.py
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/py-posix1e/distinfo b/security/py-posix1e/distinfo
new file mode 100644
index 000000000000..39dccdebcda3
--- /dev/null
+++ b/security/py-posix1e/distinfo
@@ -0,0 +1 @@
+MD5 (pylibacl-0.2.1.tar.gz) = a1c3638fae0630dfa715f9143bd71ad5
diff --git a/security/py-posix1e/pkg-comment b/security/py-posix1e/pkg-comment
new file mode 100644
index 000000000000..be78071b9b81
--- /dev/null
+++ b/security/py-posix1e/pkg-comment
@@ -0,0 +1 @@
+Python module for manipulating POSIX.1e ACLs
diff --git a/security/py-posix1e/pkg-descr b/security/py-posix1e/pkg-descr
new file mode 100644
index 000000000000..f2e1121e51f2
--- /dev/null
+++ b/security/py-posix1e/pkg-descr
@@ -0,0 +1,3 @@
+This module provides support for manipulating POSIX.1e ACLs.
+
+WWW: http://pylibacl.sourceforge.net/
diff --git a/security/py-posix1e/pkg-plist b/security/py-posix1e/pkg-plist
new file mode 100644
index 000000000000..1a97e6c1b6da
--- /dev/null
+++ b/security/py-posix1e/pkg-plist
@@ -0,0 +1,8 @@
+%%PYTHON_SITELIBDIR%%/posix1e.so
+share/doc/py-posix1e-0.2.1/BENCHMARK
+share/doc/py-posix1e-0.2.1/IMPLEMENTATION
+share/doc/py-posix1e-0.2.1/PLATFORMS
+share/doc/py-posix1e-0.2.1/README
+share/doc/py-posix1e-0.2.1/posix1e.html
+share/doc/py-posix1e-0.2.1/posix1e.txt
+@dirrm share/doc/py-posix1e-0.2.1