aboutsummaryrefslogtreecommitdiff
path: root/security/py-pyclamd
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-08-01 05:58:31 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-08-01 05:58:31 +0000
commitabda914437b027a13ef54b1aca85097880f81cdb (patch)
treee78523050adc0de6c106a302b77bb4a09fdb0d0f /security/py-pyclamd
parent700411884b0a92d79baaa8a383e64c8fe48276b4 (diff)
downloadports-abda914437b027a13ef54b1aca85097880f81cdb.tar.gz
ports-abda914437b027a13ef54b1aca85097880f81cdb.zip
security/py-pyclamd: 0.2.2 -> 0.3.17
- now compatible with python 3 - API now object oriented. Useful classes are ClamdNetworkSocket and ClamdUnixSocket. - patches makepatch compliant - added WWW PR: 211125 Approved by: bsd@dino.sk (maintainer timeout)
Notes
Notes: svn path=/head/; revision=419425
Diffstat (limited to 'security/py-pyclamd')
-rw-r--r--security/py-pyclamd/Makefile26
-rw-r--r--security/py-pyclamd/distinfo5
-rw-r--r--security/py-pyclamd/files/patch-pyclamd.py38
-rw-r--r--security/py-pyclamd/files/patch-setup.py19
-rw-r--r--security/py-pyclamd/pkg-descr2
5 files changed, 14 insertions, 76 deletions
diff --git a/security/py-pyclamd/Makefile b/security/py-pyclamd/Makefile
index 6c37d1834482..f1a154eb141e 100644
--- a/security/py-pyclamd/Makefile
+++ b/security/py-pyclamd/Makefile
@@ -1,27 +1,19 @@
# Created by: Milan Obuch
# $FreeBSD$
-PORTNAME= pyclamd
-PORTVERSION= 0.2.2
+PORTNAME= pyClamd
+PORTVERSION= 0.3.17
CATEGORIES= security python
-MASTER_SITES= http://xael.org/norman/python/pyclamd/
-DISTFILES= pyclamd.py
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= bsd@dino.sk
COMMENT= Python ClamD interface module
-USES= python
-USE_PYTHON= distutils autoplist
-
-.include <bsd.port.pre.mk>
+LICENSE= LGPL3+
-do-extract:
- @${RM} -rf ${WRKDIR}
- @${MKDIR} ${WRKDIR}
- @${MKDIR} ${WRKDIR}/${PKGNAME}
- if ! (cd ${WRKDIR} && ${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}/${PKGNAME}/); \
- then \
- exit 1; \
- fi; \
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/py-pyclamd/distinfo b/security/py-pyclamd/distinfo
index d68589defde3..725021ba24ca 100644
--- a/security/py-pyclamd/distinfo
+++ b/security/py-pyclamd/distinfo
@@ -1,2 +1,3 @@
-SHA256 (pyclamd.py) = 209673f947ce16d53bab43c19bfb8200f8b40cc70b26d4dbc9a0e203c561d16e
-SIZE (pyclamd.py) = 13101
+TIMESTAMP = 1468687659
+SHA256 (pyClamd-0.3.17.tar.gz) = 9921a582c45baa34dabb357c548c5ed331b9a39334881b3a784b593680b07ba0
+SIZE (pyClamd-0.3.17.tar.gz) = 10737
diff --git a/security/py-pyclamd/files/patch-pyclamd.py b/security/py-pyclamd/files/patch-pyclamd.py
deleted file mode 100644
index a80e2f2df701..000000000000
--- a/security/py-pyclamd/files/patch-pyclamd.py
+++ /dev/null
@@ -1,38 +0,0 @@
---- pyclamd.py.orig 2011-01-26 20:08:38.000000000 +0100
-+++ pyclamd.py 2011-01-26 20:14:58.000000000 +0100
-@@ -51,7 +51,7 @@
- # Network
- pyclamd.init_network_socket('localhost', 3310)
- # Unix local socket
-- #pyclamd.init_unix_socket('/var/run/clamd')
-+ #pyclamd.init_unix_socket('/var/run/clamav/clamd.sock')
-
- # Get Clamscan version
- print pyclamd.version()
-@@ -66,7 +66,7 @@
- Test strings :
- ^^^^^^^^^^^^
- >>> try:
--... init_unix_socket('/var/run/clamav/clamd.ctl')
-+... init_unix_socket('/var/run/clamav/clamd.sock')
- ... except ScanError:
- ... init_network_socket('localhost', 3310)
- ...
-@@ -110,7 +110,7 @@
-
- # Default values for globals
- use_socket = None
--clamd_SOCKET = "/var/run/clamav/clamd.ctl"
-+clamd_SOCKET = "/var/run/clamav/clamd.sock"
- clamd_HOST = '127.0.0.1'
- clamd_PORT = 3310
- clamd_timeout = None #[PL] default timeout for sockets: None = blocking operations
-@@ -121,7 +121,7 @@
-
- ############################################################################
-
--def init_unix_socket(filename="/var/run/clamav/clamd.ctl"):
-+def init_unix_socket(filename="/var/run/clamav/clamd.sock"):
- """
- Init pyclamd to use clamd unix local socket
-
diff --git a/security/py-pyclamd/files/patch-setup.py b/security/py-pyclamd/files/patch-setup.py
deleted file mode 100644
index 29b7fcfcb8b3..000000000000
--- a/security/py-pyclamd/files/patch-setup.py
+++ /dev/null
@@ -1,19 +0,0 @@
---- setup.py.orig 2009-01-07 13:42:10.000000000 +0100
-+++ setup.py 2009-01-07 13:42:27.000000000 +0100
-@@ -0,0 +1,16 @@
-+#!/usr/bin/python
-+
-+import glob
-+import os
-+import sys
-+from distutils.core import setup
-+
-+setup(name="pyclamd",
-+ version="0.2.2",
-+ description="Python ClamD module.",
-+ author="Alexandre Norman",
-+ author_email="norman@xael.org",
-+ url="http://xael.org/norman/python/pyclamd/",
-+ license="GPL",
-+ packages=['']
-+ )
diff --git a/security/py-pyclamd/pkg-descr b/security/py-pyclamd/pkg-descr
index eed312fdeeaf..8f61ca8cea0f 100644
--- a/security/py-pyclamd/pkg-descr
+++ b/security/py-pyclamd/pkg-descr
@@ -1,3 +1,5 @@
pyClamd is a python interface to Clamd (Clamav daemon).
By using pyClamd, you can add virus detection capabilities
to your python software in an efficient and easy way.
+
+WWW: http://xael.org/pages/pyclamd-en.html