aboutsummaryrefslogtreecommitdiff
path: root/security/py-pynacl
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2016-01-04 07:55:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2016-01-04 07:55:31 +0000
commitcc39ba75eae0bb2939c52cad26c2fc3d5ffd10bd (patch)
tree3cebfd04883ee30c233f201d89dc9990454d341e /security/py-pynacl
parent2b0db1bb144ab80fbc0e956aa0e70913b7527f89 (diff)
downloadports-cc39ba75eae0bb2939c52cad26c2fc3d5ffd10bd.tar.gz
ports-cc39ba75eae0bb2939c52cad26c2fc3d5ffd10bd.zip
Notes
Diffstat (limited to 'security/py-pynacl')
-rw-r--r--security/py-pynacl/Makefile28
-rw-r--r--security/py-pynacl/distinfo2
-rw-r--r--security/py-pynacl/files/patch-setup.py14
-rw-r--r--security/py-pynacl/pkg-descr4
4 files changed, 48 insertions, 0 deletions
diff --git a/security/py-pynacl/Makefile b/security/py-pynacl/Makefile
new file mode 100644
index 000000000000..513d46268ed3
--- /dev/null
+++ b/security/py-pynacl/Makefile
@@ -0,0 +1,28 @@
+# Created by: Yuri Victorovich <yuri@rawbw.com>
+# $FreeBSD$
+
+PORTNAME= pynacl
+PORTVERSION= 0.3.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PyNaCl-${PORTVERSION}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= PyNaCl is a Python binding to the Networking and Cryptography library
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnacl.a:${PORTSDIR}/security/nacl \
+ ${PYTHON_PKGNAMEPREFIX}cffi>0:${PORTSDIR}/devel/py-cffi
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>0:${PORTSDIR}/devel/py-cffi
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/nacl/_lib/_cffi__xfc5fefe5xfb751af7.so
+
+.include <bsd.port.mk>
diff --git a/security/py-pynacl/distinfo b/security/py-pynacl/distinfo
new file mode 100644
index 000000000000..28bccb7e9299
--- /dev/null
+++ b/security/py-pynacl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PyNaCl-0.3.0.tar.gz) = 124997314455605f61afae6cf8b99b32d10f2dba22f114acb4c80d352eed76c2
+SIZE (PyNaCl-0.3.0.tar.gz) = 2569604
diff --git a/security/py-pynacl/files/patch-setup.py b/security/py-pynacl/files/patch-setup.py
new file mode 100644
index 000000000000..440d371b752c
--- /dev/null
+++ b/security/py-pynacl/files/patch-setup.py
@@ -0,0 +1,14 @@
+--- setup.py.orig 2015-03-04 07:00:53 UTC
++++ setup.py
+@@ -167,9 +167,10 @@ class build_clib(_build_clib):
+ build_temp = os.path.abspath(self.build_temp)
+
+ # Ensure our temporary build directory exists
++ print("YURI build_temp="+build_temp)
+ try:
+ os.makedirs(build_temp)
+- except IOError:
++ except:
+ pass
+
+ # Ensure all of our executanle files have their permission set
diff --git a/security/py-pynacl/pkg-descr b/security/py-pynacl/pkg-descr
new file mode 100644
index 000000000000..2c5e91eed5c4
--- /dev/null
+++ b/security/py-pynacl/pkg-descr
@@ -0,0 +1,4 @@
+PyNaCl is a Python binding to the Networking and Cryptography library, a crypto
+library with the stated goal of improving usability, security and speed.
+
+WWW: https://pypi.python.org/pypi/PyNaCl/