aboutsummaryrefslogtreecommitdiff
path: root/security/py-pysaml2
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2016-01-08 04:44:16 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2016-01-08 04:44:16 +0000
commit86ce13e106e71e7db42bdecdfbc75d5a1312b126 (patch)
tree1dd8fb73f9c6530baf34671030c4dc165efeed7f /security/py-pysaml2
parentd15a2a3cec33dbc63340052213ce6d244ec17f4d (diff)
[NEW] security/py-pysaml2: Python implementation of SAML Version 2
PySAML2 is a pure python implementation of SAML2. It contains all necessary pieces for building a SAML2 service provider or an identity provider. The distribution contains examples of both. Originally written to work in a WSGI environment there are extensions that allow you to use it with other frameworks. WWW: https://github.com/rohe/pysaml2 PR: 205914 Submitted by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
Notes
Notes: svn path=/head/; revision=405519
Diffstat (limited to 'security/py-pysaml2')
-rw-r--r--security/py-pysaml2/Makefile39
-rw-r--r--security/py-pysaml2/distinfo2
-rw-r--r--security/py-pysaml2/files/patch-tests_test__52__default__sign__alg.py12
-rw-r--r--security/py-pysaml2/files/patch-tests_test__84__entcat.py12
-rw-r--r--security/py-pysaml2/pkg-descr6
5 files changed, 71 insertions, 0 deletions
diff --git a/security/py-pysaml2/Makefile b/security/py-pysaml2/Makefile
new file mode 100644
index 000000000000..0649cf31047f
--- /dev/null
+++ b/security/py-pysaml2/Makefile
@@ -0,0 +1,39 @@
+# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
+# $FreeBSD$
+
+PORTNAME= pysaml2
+PORTVERSION= 4.0.1
+CATEGORIES= security devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= brendan+freebsd@bbqsrc.net
+COMMENT= Python implementation of SAML Version 2
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}decorator>0:${PORTSDIR}/devel/py-decorator \
+ ${PYTHON_PKGNAMEPREFIX}requests>1.0.0:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}Paste>0:${PORTSDIR}/www/py-paste \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}repoze.who>0:${PORTSDIR}/devel/py-repoze.who \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>2.5:${PORTSDIR}/security/py-pycrypto \
+ ${PYTHON_PKGNAMEPREFIX}pytz>0:${PORTSDIR}/devel/py-pytz \
+ ${PYTHON_PKGNAMEPREFIX}openssl>0:${PORTSDIR}/security/py-openssl \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>0:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}six>0:${PORTSDIR}/devel/py-six \
+ xmlsec1:${PORTSDIR}/security/xmlsec1
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}responses>0:${PORTSDIR}/devel/py-responses
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+do-test:
+ @(cd ${WRKSRC} && ${PYTHON_CMD} -m pytest)
+
+.include <bsd.port.mk>
diff --git a/security/py-pysaml2/distinfo b/security/py-pysaml2/distinfo
new file mode 100644
index 000000000000..5a8850b7722b
--- /dev/null
+++ b/security/py-pysaml2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pysaml2-4.0.1.tar.gz) = 8bd010ceac7b0c29b7bd67bd5b7bc993f3975eae67f8c49b4bf89a8dc4e5a948
+SIZE (pysaml2-4.0.1.tar.gz) = 13656835
diff --git a/security/py-pysaml2/files/patch-tests_test__52__default__sign__alg.py b/security/py-pysaml2/files/patch-tests_test__52__default__sign__alg.py
new file mode 100644
index 000000000000..34031e5fb7f0
--- /dev/null
+++ b/security/py-pysaml2/files/patch-tests_test__52__default__sign__alg.py
@@ -0,0 +1,12 @@
+--- tests/test_52_default_sign_alg.py.orig 2015-12-23 21:15:07 UTC
++++ tests/test_52_default_sign_alg.py
+@@ -8,7 +8,8 @@ from saml2.samlp import response_from_st
+ from saml2.server import Server
+ from saml2 import client
+ from saml2 import config
+-from mock.mock import Mock, MagicMock
++# mock.mock seems to rely on pre-2.7 packaging
++from mock import Mock, MagicMock
+ import saml2.xmldsig as ds
+
+ nid = NameID(name_qualifier="foo", format=NAMEID_FORMAT_TRANSIENT,
diff --git a/security/py-pysaml2/files/patch-tests_test__84__entcat.py b/security/py-pysaml2/files/patch-tests_test__84__entcat.py
new file mode 100644
index 000000000000..d2f949686019
--- /dev/null
+++ b/security/py-pysaml2/files/patch-tests_test__84__entcat.py
@@ -0,0 +1,12 @@
+--- tests/test_84_entcat.py.orig 2015-12-23 21:20:13 UTC
++++ tests/test_84_entcat.py
+@@ -72,7 +72,8 @@ def test_entcat_filter():
+
+ mds = MetadataStore(ATTRCONV, sec_config,
+ disable_ssl_certificate_validation=True)
+- _path = "testfed-metadata.xml"
++ # Incorrect path was being derived
++ _path = full_path("testfed-metadata.xml")
+ mds.imp(
+ {"local": [_path]})
+
diff --git a/security/py-pysaml2/pkg-descr b/security/py-pysaml2/pkg-descr
new file mode 100644
index 000000000000..3abc24872c43
--- /dev/null
+++ b/security/py-pysaml2/pkg-descr
@@ -0,0 +1,6 @@
+PySAML2 is a pure python implementation of SAML2. It contains all necessary
+pieces for building a SAML2 service provider or an identity provider. The
+distribution contains examples of both. Originally written to work in a WSGI
+environment there are extensions that allow you to use it with other frameworks.
+
+WWW: https://github.com/rohe/pysaml2