aboutsummaryrefslogtreecommitdiff
path: root/security/py-pyscard
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-12-19 16:07:01 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-12-19 16:07:01 +0000
commitf2cfdf283d966863cd4d44359cde68e05e98c3bb (patch)
tree01303b31fa5bc59b9b0311180334062a02bed201 /security/py-pyscard
parente51eda6b05d3e64b338341b133e685058f240d9b (diff)
downloadports-f2cfdf283d966863cd4d44359cde68e05e98c3bb.tar.gz
ports-f2cfdf283d966863cd4d44359cde68e05e98c3bb.zip
switch from swig 1.3 to 3.0
Notes
Notes: svn path=/head/; revision=456733
Diffstat (limited to 'security/py-pyscard')
-rw-r--r--security/py-pyscard/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/security/py-pyscard/Makefile b/security/py-pyscard/Makefile
index ccaf6e4726f5..69ec1ef3612c 100644
--- a/security/py-pyscard/Makefile
+++ b/security/py-pyscard/Makefile
@@ -13,13 +13,14 @@ COMMENT= Smartcard module for Python
LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= swig1.3:devel/swig13 \
+BUILD_DEPENDS= swig3.0:devel/swig30 \
pcsc-lite>0:devel/pcsc-lite
RUN_DEPENDS= pcsc-lite>0:devel/pcsc-lite
## Python3 is supported
USES= python:2.7+
USE_PYTHON= autoplist distutils
+BINARY_ALIAS= swig=swig3.0
PYDISTUTILS_BUILD_TARGET= build_ext
PYDISTUTILS_BUILDARGS+= --include-dirs=${LOCALBASE}/include/PCSC